Debian - AppImage - "Remember password" doesn't work

Hello,

I’m using the appimage on my Debian, and i want to unlock a vault after Cryptomator starting up, but the option “remember password” doesn’t work : Cryptomator always ask me the password.

Do you know how to fix it ?

Thank you

Cordially

Welcome to the Cryptomator Community :slightly_smiling_face:,

To store the password, Cryptomator uses on Linux KDWallet or GNOME Keyring. Is any of the two installed on your system?

Hello and thank you :slight_smile:

Yes i’ve got Gnome Keyrong install, but it won’t work…

For the GNOME Keyring to work, the default keyring (named “Login”) must be present. You can view the name of your keyrings with Seahorse. Also, if this keyring is not present, you can create it with that app.

In the following screenshot your keyrings are listed below “Passwords”:
Screenshot from 2022-08-16 10-32-21

Hello.

Thanks, missed the keyring “Login”.

I manually created it but the problem is still here…

Do you see the Keyring selected in the Cryptomator settings?

If so can you please enable debug mode, try to store the password and then have a look into the log file, are there some ERROR, WARNING entries?

Yes the GNOME Keyring is selected :

and this is the log when i unlock a vault named Images :

Thanks for your help :slight_smile:

What Cryptomator version are you using? With 1.6.11 a bug was introduced, which prevented the settings to be persisted and hence also not communicated, that your password should be stored.

Yesterday we released Cryptomator 1.6.14, which fixes the issue. You can download it from your Github repository.

Hello.

Thanks for your help.

I’ve update Cryptomator to version 1.6.14 but i still have the problem…

© 2022 Skymatic GmbH • Privacy PolicyImpressum