Cryptomator0.log OneDrive sync error "This file is in use", I am using on Windows and Android

Very frequently, I get the following OneDrive sync error message in Windows due to Cryptomator:

This file is in use
This item is open in another program. Close the item to continue syncing it.

I guess it is because Cryptomator for Windows and the Cryptomator for Android are willing to edit this log file. How to fix this?

Generall question: Does this issue appear specific to this file?

Im asking, because cryptomator0.log is generally nothing which should be synced. It is stored in directory which is local to your machine and application and can contain sensitive data.

And yes, while Cryptomator Desktop is running, it uses the file to write the application log. It is unrelated to the Android app.

Thanks for your help. Yes, the problem only appear with cryptomator0.log and never with the other log files that are in the same directory.
How can I disable the log ? or how can I change the location of the logs ?
most application allow to disable logs, and to change their location.

The log cannot be disabled.

Changing the log dir cannot be performed from within Cryptomator. Open the file [INSTALLDIR_CRYPTOMATOR]/app/Cryptomator.cfg with a texteditor and change the value of the key java-options=-Dcryptomator.logDir to a different path.

In the config file [INSTALLDIR_CRYPTOMATOR]/app/Cryptomator.cfg I have changed the line:
with (after having created the the Temp and Cryptomator folders):

but when I start Cryptomator, the .cfg file is overwritten and it is going back to:
I guess it is because C:\Temp\Cryptomator was not understood. How can I enter an absolute path in this .cfg ?

It seems like you are using the portable version of Cryptomator. I don’t know if they use a mechanism to ensure always the same files are used. With the normal installed application it works.

Yes, I am using Cryptomator portable.
But it is apparently working just the same: the logs are created into /data/log folder as well.
I think I just need to enter an absolute path instead of the relative one, so I just need the syntax to use in this .cfg file.

I have created a github issue about it but go no answer:

Absolute Paths do work, there is no special syntax (well, except if there would be spaces in the file path). When I enter C:\Users\MyUsername\logDir the logs are written to the specified directory.

I have tried with a very simple path like yours, it does not work with Cryptomator portable: the .cfg is again overwritten when I start Cryptomator portable.

That’s a pity CryptomatorPortable dev is not using the original config file. I have checked the website, nothing about this here and when looking inside yaml, json files there is nothing as well. I guess the portable Cryptomator has the log path hardcoded. This means it is impossible to have Cryptomator Portable on a cloud storage service which severely reduce the purpose of using a portable app.