Cryptomator v2 not loading on iOS 15.4

Device: iPhone 13 Pro Max and iPad 12.9 5th Gen M1
OS: iOS and iPadOS 15.4 Dev Beta 2
App: Cryptomator 2 v 2.1.1

I’ve had virtually no issues with Cryptomator 2 until the latest update - v2.1.1 installed itself yesterday.

The Files App says “Content Unavailable: The folder contents could not be displayed because of an unknown error.” And upon opening the Cryptomator App, I just get a black screen that never goes anywhere or shows anything.

I’ve tried deleting the app and reinstalling, but it won’t go further than opening and sitting there with a blank screen. I’m not entirely sure if this is a compatibility with iOS 15.4 or if the latest version of the app broke things?

I am able to see the vaults and their contents if I install the old version of Cryptomator, but obviously don’t want to keep playing around with that and corrupting the volume if they’re different volumes.

Any ideas?

Sounds like an issue with iOS 15.4 Beta. There were several other reports here as well:

I can’t think of anything right now that should’ve happened between Cryptomator 2.1.0 and 2.1.1 with such a big impact. Of course, there were a lot of changes but we didn’t even update Xcode, update dependencies (except of our own libraries) or anything like that.

Could you please go to iOS Settings > Privacy > Analytics & Improvements > Analytics Data and search for “cryptomator” or “FileProviderExtension”? Maybe there is a helpful log or crash report or something like that.

Thank you for reporting this issue. We’ll keep investigating.

I think we’re getting closer and this will require an update of Cryptomator. Progress on that will be reported here:

1 Like

Where would you like me to send the logs to?

And there’s like 20 entries per device. Is there an easy way to grab all 20 to zip up and send?

Thank you but that’s not necessary anymore. Update 2.1.2 is on its way (has to go through Apples’s App Review though).

1 Like

Any chance you’ll start pushing updates to the TestFlight testers first?

Version 2.1.2 (838) should be available using TestFlight

Unless I’m on the wrong TestFlight, I have 2.0.0 (722). Could you add me or PM me a link please? :grinning:

Sorry I was wrong, it is not yet available in the public Testflight channel :sweat_smile:

I’m sorry, we’re currently unable to offer public TestFlight updates because we’d need to fix something in our build system first.

Hi, not sure if I’m really facing the same issue here but I have a problem which produces the same error message:

Version is already 2.1.2 (838).

Must this be a different issue? Or wasn’t it (completely) fixed with this version?
Provider is pCloud and I don’t get this error always but about 50% of the time when browsing to another directory which is quite annying.

Hi @MarcelB,

this is a different bug, as the bug discussed in this thread caused the iOS app to always crash. This is not the case with the error you describe.

However, you are welcome to send us the log file so that we can investigate your problem in more detail.
How to export the log file from the Cryptomator 2.0 iOS app is described here: Settings — Cryptomator 1.6.0 documentation

You can send it to