Cryptomator sehr langsam mit Dokany, Webdav ändert die Adressse immer

Hi all,
I use Cryptomater 1.5.x on a OneDrive cloud.
If I use Webdav, the name of the drive (not the letter) changes every restart, therefor links dated out.
No I try Dokany (with drive letter and with mount point), but often I waitws minutes for the files. (OneDrive is configured to keept the files on my Computer, Cloud-UJpdate is not the problem…)

How can I speed up? Are ther configuration options? Where?

Thanks for help
Dierk

Welcome to the Cryptomator Community :slight_smile:

You can fix the drive letter by accessing the vault specific options and switch to the “Mounting” tab. The options are only accessible from the vault detail view and if the vault is locked.

This description is too unspecific to help you. What are you waiting for to happen? If you use the auto-unlock feature, currently a lot of user experience issues with auto-unlocking with Dokany on system start up.

I had problems moving multiple files to and within the Cryptomator Dokany Drive, placed on a Dropbox/Drive/Ondrive equivalent.

Especially involving folders with files in them already. Took ages to just move 200 images, even to the point of explorer freezing.

Problem:

  • Selected multiple files on a local HDD, or a folder (ea Whatsapp Images folder)
  • Paste files/folder into Cryptomator Dokany Drive (Y:)
  • The larger the number of files, the longer it took to even come to the “would you like to skip/overwrite files that are already there”, if it got there at all. Copying 1000 .jpg files would take multiple hours to even get to it.
  • This did not happen while copying to an empty folder

Solution:
I removed Dokany Library 1.4.something and installed the pre-release Dokany Library 2.0 (https://github.com/dokan-dev/dokany/releases/tag/v2.0.0-BETA2)

Problem solved, enormous speed improvement, everything goes as smooth as transferring files between two local HDDs, no crashing until now and already moved 1000’s of files without a hassle. Don’t know how stable the beta is, but works perfectly fine so far.

1 Like

HI, thanks,… but how do I connect cryptomator to the new lib? After installing the new version, cryptomator cannot locate dokany…
Dierk

I’m not sure, but must say I’m also no expert. You uninstalled the old dokany library, installed the new one, and now Cryptomator does not work? Did you try re-installing them both? Or maybe uninstall both with something like Geek so it deletes some leftover files

It helps to be very specific about what you tried and what problems pop up, maybe include helpful screenshots

For other users I’d like to add here something before a lot of people try this:

This apporach is completely experimental. No guarantee for the safety of your data can be given and we won’t give any support for it.

While it’s cool someone experiments already with the next generation of Dokany, there is absolutely no guarantee that this works stable and reliable. Hence, make backups and please do not consider this as a good workaround! That said, we are glad about any feedback with it :wink:

© 2020 Skymatic GmbH • Privacy PolicyImpressum