Cryptomator on Raspberry Pi 3 (JavaFX-Problem?)

Hello,

in Raspian (strech) there is no cryptmator-Package (armhf). I purged all previos installed openjdk-versions and installed Java8 and Java JDK from oracle. But i cannot start cryptomator. I searched the web and found the information, that JavaFX has been removed vom JDK for arm. I tried to install JavaFX manually and tried varios ways I found at the web. Now the App starts, no errors, but no gui.

How can I solve the problem?

Thank you,

Michael

Not sure if you can solve the JavaFX problem at all. I haven’t done any research on it, to be honest. You might experiment with Cryptomator CLI that works without a UI: https://github.com/cryptomator/cli

It’s currently in beta but you can share your experience with it and let us know if it works on Raspberry Pi.

Hi,

the CLI-Version works perfect on RPI3. Thank you.

How beta is the beta-Version still? Is it very unsecure to work with private data? When there will be a regular version?

Greetings!

Michael

The CLI beta is based on the same released crypto libraries as the desktop version. Thus the file encryption works the same way and is in fact not beta. Some features are missing in the CLI version though, e.g. the possibility to protect the webdav server with a password and similar stuff.

Hey Michael, after running the cli with java were you able to mount the vault locally with davfs?

cryptomator-cli has not been updated since V6 of the file structure. If you try to run it now on an up-to-date cryptomator data set, it will error out saying it doesn’t support V7.

it was updated recently.

Aaand today its offical:

© 2020 Skymatic GmbH • Privacy PolicyImpressum