Cryptomator inside iOS Files app fails


#1

I just started using Cryptomator on Mac and iOS and everything is working great inside the iOS app so far.

On iOS 11.2.6, I launch Cryptomator and unlock my vault and see the contents as expected, then I open up Files, tap Browse and select Cryptomator. All I get is a quick screen flash and then I am right back to the Browse view.

Is Files support supposed to work? Is there already a fix in the works for this issue??

Thanks for great encryption option!
Lee


Wann kommt endlich die UnterstĂĽtzung der Dateien App?
Cryptomator & iOS File App
Files App integration
Cryptomator & iOS Files App
#2

Can you please describe in more detail what exactly you are doing, what you expect and how the system actually behaves? I tried to reproduce the error, but the file view works fine for me. (on 11.2.6)


#3

I have Cryptomator setup with a single vault, created using iOS and located on iCloud which means that it is inside the Vaults subdirectory. When I open the vault (named Private) in the iOS Cryptomator app I can view work with the file as expected.

If I launch iOS Files app (NOT the Cryptomator app) with Cryptomator turned on as a Location and then in the Browse Locations view tap on Cryptomator I get a very quick window opening and then it disappears so I see the Browse Locations again.

On an iPhone this looks like a blinking screen, but on iPad the pop-up is not full screen so I can see the pop-up view very quickly with a spinning progress circle and then it disappears.

This appears to be an incompatibility with the current Cryptomator build and the current iOS build including the Files app or Files Locations support isn’t really implemented yet…

I was excited about Cryptomator showing up as a Location option so that is the first thing I tried after setting up a vault.

Thanks, Lee


#5

That’s a known problem. I have looked at GitHub and found a related issue.
Bug: Cryptomator do not open in new ios Files app #98


#6

Thanks. I would even give up Move/Delete (from Github comments) inside Files since I really only want to share a file to an app right from Files…

Any idea when this might get fixed??


#7

Mittlerweile ist Cryptomator bei mir die einzige nicht funktionierende App im Zusammenspiel mit der Dateien App. Sogar MagentaCLOUD hat’s geschafft.
Cryptomator wird beim Durchsuchen/HinzufĂĽgen-Modus zwar angezeigt, stĂĽrzt aber ohne Wirkung kommentarlos zum Auswahlbildschirm zurĂĽck.

iOS 11.2.6, iPhone 6s und iPhone X


#8

Hello I recently purchased the iOS app and am having the same problem ie Cryptometer doesn’t work in iOS files app. Are you going to be addressing this issue soon? Thanks. Ben


#9

Hello? Is anyone supporting this application? Is this the best place to log issues? Thank you.


#10

Hallo,
gibt es zu diesem Problem etwas Neueres ?


#11

Hi,

I love Cryptomator, thanks for a fantastic app that provides privacy for all.

The issue has probably been brought up before; however, are there any plans to get cryptomator to work with the iOS Files App?

When I try to save a file to or access a file in Cryptomator using the iOS Files App I cannot open cryptomator within the iOS Files App.

I would love to be able to use Cryptomator with the iOS App.


#12

Ah, at least i now see, that others also have this problem.

It effectively renders Cryptomator useless on iOS 11.

Only with this File Provider, users are able to save things encrypted into the configured Cloud storage.

I want to use all my content over the Cryptomator File Provider …
Please fix this.

And: Please add some “Buy me a coffee” IAP!!!
I want to give something back.


#13

Hi, I agree that it would be great if Cryptomator worked with Files. Don’t quite understand file in ios but the more file management is facilitated the better (because it was awful) and being able to encrypt files is important to me.


#14

+1 for fixing this issue. Major bugbear. Effectively means you cant edit files in iOS - you have to copy to the app and then copy back - which is the reason why the document picker was introduced in iOS 11