Cryptomator + git + Windows 10 = doesn't work at all :-(


#1

Hello,
It is the second time that I have to do a git clone because my deposit on Cryptomator partition doesn’t work: I use the last version of Cryptomator and last git on windows 10 64bit and some time my git deposit is completly blocked, I have to do a git clone again nd again:
λ git status
fatal: failed to read object 7a1d5e63c878c51a9311908c355c96bc45e7e4dc: Permission denied

I try many thing with git, but nothing works and I cannot delete file, I can rename the folder like this: “delete_me_if_you_can” …

this is a very dirty issue so Cryptomator is still very unstable. I have also issue on macos when I open docx file with Word, Word has writting problem and make many many many temporary files and at the end you cannot write the document, or you think the document was saved but othing was written…

I’m very ungry with Cryptomator that I use every day


#2

λ git clone “\aaaa.fr\Dossiers\Production\PPP\Forfait\EEE\VBA Excel DCID\Production\GIT” && mv GIT git_doc
Cloning into ‘GIT’…
done.
error: unable to append to ‘Z:/AA/Projet AA/EEE/DCID/git/GIT/.git/logs/refs/remotes/origin/HEAD’: No space left on device
fatal: update_ref failed for ref ‘HEAD’: cannot update the ref ‘HEAD’: unable to append to ‘Z:/AA/Projet AA/EEE/DCID/git/GIT/.git/logs/HEAD’: No space left on device
fatal: the remote end hung up unexpectedly

but I have place on it…


#3

So I did outside cryptomator disk the git clone, it works, then I copy the folder into the cryptomator disk and I try a “git add”, this is the error I have:

λ git add file.cpp
warning: unable to unlink ‘.git/objects/8d/tmp_obj_Mz4usa’: Bad file descriptor
error: unable to write sha1 filename .git/objects/8d/1a73ba0151fec12277b5379dca9de9a07eddc9: Bad file descriptor
error: file.cpp: failed to insert into database
error: unable to index file file.cpp
fatal: updating files failed

so cryptomator last version is not working at all with git …
is it a pre-alpha software ?


#4

Cryptomator is designed for storing encrypted files online via (a slow) internet connection. It’s purpose is not to work as encrypted partition where software is running in.
I guess this is why there are often problems when people try to run software direct from the vault.
This is just not cryptomator was created for.
I recommend veracrypt if you want to encrypt local used partitions.

https://community.cryptomator.org/search?context=topic&context_id=746&q=Veracrypt&skip_context=true


#5

Hi, thank you for the answer
I use Cryptomator with google Drive, so If I anderstand what you day, Cryptomator is not made for files that are edited, it is just for storing very simple kind of files… (txt files, maybe some binaries with simple properties…) ?

but Veracrypt is horrible with cloud beacause we have only one big and fat file… what I need is a possibility to read, write and edit file shared on the cloud, too bad :frowning:


#6

No, I said cryptomator is not made for running software direct from the vault. It’s a differens if you edit files, or if you are executing files. As an example: there are tons of software that can not be executed from a network drive, although you can of course edit files in a network share.

If you want to have an encrypted backup of your git, you can backup git into a cryptomator vault using backup or folder-sync tools.
If you want to have a local encryption of the git you are working with, then you should use veracrypt to encrypt your local environment.
If you want to have both, well then I recommend a combination: encrypt your local files with veracrypt, and backup (the unencrypted files) into a vault for an encrypted online backup.


#8

If you want to have an encrypted backup of your git, you can backup git into a cryptomator vault using backup or folder-sync tools.
ok, so I just make a new disk, and I put only backups of files and folders on it now, but I still have files and folders impossible to delete… sorry but the version just before 1.4 worked better, the 1.4 is not ready for production at all !!!