Cryptomator for Mac broken after update to 1.7.1

I am mainly using Cryptomator on my M1 MacBook that runs Ventura 13.2 and my vault is on Google Drive. Since I upgraded to Cryptomator 1.7.1 the client is a broken mess.

When I was on 1.6.xx everything worked fine, and I was still using MacFuse.

Then I upgraded to 1.7.1, removed MacFuse and installed Fuse-t as instructed.

I can read files in my Vault, but I can’t write to it. When I try to upload something to my vault, one of these three things happens:

  • Google Drive doesn’t upload the file (it appears to stay in the local cache, so the file is visible only on my Mac)
  • macOS gives me error -36 and the files doesn’t even make it to the local cache
  • It looks like Google Drive uploads the file, but when I check Cryptomator on my Android phone, it’s not there.

Also, when I open my vault via the Android app (1.7.5 version), it’s full of .fuse-Files that should be hidden. Files that I upload via the Android on the other hand are being synched and are available on my Mac. So there’s that at least.

Another vault that I have on my GDrive “unlocks” but when I want to look at it, it’s just empty. No files, no folders, nothing.

All these errors and bugs occur, no matter if I’m using Fuse-t or WebDav (AppleScript).

Can anyone please help? I don’t know what to do and I desperately need my vaults to just work because I am using them at work :frowning:

Are you sure that it has something to do with FUSE-T (or even WebDAV)? I mean, you could re-install macFUSE. If that works for you, then there is no reason to stop using it. Be aware, that you have to restart Cryptomator if you change the volume type setting.

And you could also use 1.6.x again, just to make sure that you’re seeing a clear difference between 1.6.x and 1.7.x.

I’ve just tried a simple test case and my Google Drive synced properly. It sounds more like a Google Drive issue, to be honest. Does Google Drive report any sync errors?

Thanks for the quick reply.

I re-installed MacFuse: Still writing to my vaults doesn’t work. At least now my second vault can be read again.

Then I downgraded to 1.6.17: I still can’t write to either of my vaults :frowning:

Google Drive is on the newest version and doesn’t show any errors.

And do you know what I can do about the dozens of .fuse_hidden-files that now flood my vaults in the android app?

Ugh, it’s getting weirder and weirder. I was able to upload one single file to my vault right now. Google Drive showed the upload and the file was available on the Android client as well. Then I wanted to upload another file, and now it’s stuck in the local cache again and Google Drive doesn’t show any uploads or errors.

Ok, I just checked if uploading files directly to my mounted Google Drive and it does. So I strongly believe that it’s a Cryptomator issue and not a Google Drive issue.