Cryptomator fails to write larger files to vault


#1

Hi all,
I have just started with Oryptomator and I’m not able to upload larger files to a cloud storage. The threshold, where it does not work anymore seems to be system dependant so I assume some sort of timing problem with Webdav.

My configuration:
2 different Windows 7,SP1 systems
Webdav connecton to Strato HighDrive or Magenta cloud (German Telekom)
1st System with 1MBit/s Uplink Speed (ADSL)
2nd System with up to 10MBit/s Uplink Speed (DSL /LTE Hybrid).

In System 1 I can copy files up to a size of 5 MByte and in System 2 around 12MByte.

I’ve played around with Webdav registry settings and the maximum file sizes are set to 4 GB. Then I tried out some timing values but there was no improvement.

When I’m uploading without Cryptomator the problem remains but the possible maximum file size is around 50MByte. So I really assume a Webdav configuration problem, but I do not have any clue, which parameters are responsible.

Any ideas? Or should I try a third storage, since Telekom and Strato use the same cloud implementation (as far as I know)

Best Regards,
Dirk


#2

Yes, there actually is a WebDAV registry key that you can configure. If the upload takes longer than 60 seconds, you’ll get the error “Could not find this item” at some point.

If that’s the case, you can increase the value of the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\SendReceiveTimeoutInSec

After that, make sure to restart the WebClient service (e.g., via Services.msc or CMD).


#3

Hi all,
I have changed the registry according your proposal, but I do not encounter any difference.
After trying that I increased all timeout values in
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters and
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MRxDAV\Parameters
to a multiple of the default values, but again there is no difference. Since I didn’t trust the restart of the Webnet-Client via services.msc I restarted the computer but it didn’t help:

I always get the same picture:

Regards, Dirk


#4

Same Problem here with Hidrive, webdav and Windows 10. Did you solve it?


#5

It is not a fix but rather a Workaround: Instead of using the WebDAV you could use Dokany as the unlocked vault provider.


#6

First impression, Dokany is still unusable slow
Cryptomator 1.4.2 / Windows 7 / HiDrive (connected via webdav)


Very slow at the new Version
#7

Still massive problems with Windows 10 / Cryptomator 1.4.2 / HiDrive (connected via webdav) / Dokany.

Opening folders takes about 10 seconds and freezes later on.


#8

Are you sure using Dokany as the unlocked vault provider is slower than WebDAV? In all my cases Dokany is now faster than WebDav. But it may depend on the hardware or size of the directory. In my case opening a directory with lots of small files (around 1200) happens nearly instantly.


#9

Absolutely sure. Dokany already needs 10 seconds to open top folder which contains only other folders, no actual files. Note as written above that Dokany keeps freezing after several Navigation steps.

Reinstalled cryptomator as well as dokany. Reboot. No improvement.

Webdav takes about 1 or two seconds.


#10

Some more information: Cryptomator/Dokany/OneDrive works fine. Even an upload of large files (>40 MB) works (see this thread Very slow at the new Version)

Strato-Webdav on its own is also working fine. So there has to be a problem with Cryptomator.


#11

Version 1.4.5: Still not able to upload large files to Strato HiDrive - neither using Dokany or webdav.