Cryptomator drive, instead of a individual drive for each vault

Zybot, I do not think you are correct

If I go into through iCloud and look at those folders, they are all encrypted

I only see the file unencrypted when I go into through Cryptomator

Please explain how you think they can be read externally


Mattis, I provided a document with instructions

Is there something specific in there that is not clear?


On your second picture it is visible that you chose a folder within iCloud Drive as mount point. That means the unencrypted data will bi synced to iCloud Drive. You can also see the cloud symbol next to the folder.

Was not a criticism just a heads up notice. I tested your remarks and it worked for me. Thank you.

May I ask where you found the -oallow_root and -olocal flags. I would like to read the manual for the flags and what else is available.

I didn’t tested this yet, but as this is the solution to solve this problem, maybe the developers (@tobihagemann ) can build this in the app for the Mac, so everyone can use this automatically.

You can find those and some more here: Mount options · osxfuse/osxfuse Wiki · GitHub

Under this scenario, unencrypted data is not synced to iCloud

Try it - if you go in to iCloud over the web or from another device you will not see data in that folder, even when it is mounted

Hey Yomama, I deeply appreciate your documentation, but unfortunately it has a very poor resolution. Could you share your instructions with a better resolution? (specifically the pictures of Cryptomator)

Here you go.

1 Like

Thank you so much. :blush:

However, it is a bit confusing when a hard drive is dormant in iCloud Drive. :sweat_smile:

Well it was a bit of trial and error to get it to work!

I managed to have it working even without the addons -olocal -oallow_root for me it was enough to just move the mount point away from /Volumes/

Also -olocal is not recommended by the developer and marked as use on own risk and possible data loss

This option marks the volume being mounted as "local". By default, macFUSE volumes are marked as
"nonlocal", which technically isn't necessarily the same as a "server" or "network" volume, but is treated
as such by the Finder in some cases. For example, the Finder may not show "connected servers" on the
Desktop or in the sidebar in some cases. If you use this option, you can get around this "limitation". 
However, wait! Don't be too tempted and think local is a magic pill that will solve all your problems. In 
fact, it may mess things up more than you realize. The operating system can be more aggressive in 
dealing with "local" volumes (a .Trashes. directory will be created, for one). You could run into mysterious 
problems with Disk Arbitration and other system components. I don't know (and possibly can't know--Mac 
OS X isn't all open source!) the side effects of using this option. Therefore, treat this as experimental and 
use with caution. Moreover, please do not file bug reports that involve this option--reproduce your issue 
without this option and then file a bug report.


I guess I should’ve pointed out that I’ve written a bug report, where I suggested some workarounds:

So from what I read, those 2 commands allow spotlight to find files in encrypted folders, otherwise you cannot find them when doing a search. It had nothing to do with mounting.

So what exactly does each one of those do?

A post was split to a new topic: Vault does not to appear on my other Apple devices in iCloud Drive

It’s been a long time since there’s been any movement on this. It’s also been a long time since I made an attempt to keep the Cryptomator vault permanently in the sidebar. Is there now a simple solution? :slight_smile:

This is easy to do if you use FUSE-T. I’ve never been able to get it to work with macFUSE.

How can I achieve this? Using Fuse-T

Install FUSE-T on your mac and ensure cryptomator has the correct volume type selected…it defaults to webDAV if you don’t have FUSE installed. FUSE-T is linked from the download page.

See this for more: