Cryptomator drive disappears (1.4.0 fuse with Mojave & High Sierra)

os:mac

#1

Hi - I know the issue is stated to be solved with FUSE and/or Mojave … bit I still have this behavior with 1.4.0 FUSE both on High Sierra and Mojave. Latest after one or two hours the drive mount is lost and I need to lock/re-unlock to get back access

What do?

Thanks for the GREAT PRODUCT … it simply needs to work …


#2

update: interestingly, when I specify a dedicated mount point, it is as follows:

  • Drive does not show up under Volumes = “Drive disappeared”

BUT

  • it is still accessible via the mount point

Hope this helps :sunglasses:


#3

… This is not just an effect within MAC-OS - so it is also in LINUX (Ubuntu 18.04LTS). And unfortunately also the “Save-PW-Function” is not working too. So I have always to dismount / mount the volume again, if I leave the mounted volume in Nautilus.

By the way: I have specified a mountpoint… but that doesn’t change anything. In Version 1.3.2 this wasn’t a problem. What I have recognized - the name of the mountpoint ist changed: There is a cryptic extension added. Here is an Example:
Name of the Mountpoint: MyMountpoint, so it is shown in Nautilus: MyMountpointjw3ri087

Hopefully that helps.

Thank you very much in advance!

Best Regards
morufusr


#4

Same on Windows 10 (Build 17134), Cryptomator Version 1.4.0

Seems that on heavy file system Operations the mounted virtual Drive disappears.
This breaks copy operations and leads to unknown project consistency.

This should be fixed quickly. There is a risk of data loss at the moment.


#5

I can not confirm this.
As my actual vaults do only contain several thousand files with a couple of GB, I tried to reproduce this “heavy file system operations”.
I created 100000 files (each 10 MB) local and moved them into the vault.
Everything worked fine.

Im using Cryptomator more than a year now and never experienced a drive disconnection.


#6

Interesting. There is an open issue on our bugtracker, where people reported this problem. Currently i got no clue where it comes from…

@p.chr can you describe what you mean with “heavy load”? Do you use some software to copy a big batch of files to the vault?


#7

I have the same problem (ever since WebDAV was introduced) on a Windows 10 machine. The drive does not “disappear” as much as the name disappears - the drive is visible, but only as “Local Disk” with the original drive letter. Cannot access it though. If an explorer window is open with the files visible I can still see them, but they aren’t “there” and refreshing the window empties it.

Interestingly, this happens only on my laptop which is on WiFi and only when it idles. Never happens when I am continually working on it. If I leave my laptop for a while and come back, and the laptop has locked screen, I can guarantee that the drive is lost. This has nothing to do with the WiFi per se (I turned off all the radios and everything worked fine). My desktop does not have this problem - it too idles, but is on a hardwired connection.

Hope this provides some additional information on troubleshooting. Thanks, by the way for an excellent piece of software!