Cryptomator doesn't start


I’m using Cryptomator for a while now in different devices, but all of them run under Windows 10. Up until now I had no problems with it.

But today I wanted to install Cryptomator on a new computer. The installation went fine, but the program doesn’t start.

There is no error message on the screen, I couldn’t find any error messages in the Windows event log either.
The cursor shows that it’s busy for a few seconds, then it’s done. In the Task Manager you see a process called “Cryptomator” for maybe a second, but this process vanishes again.

I already reinstalled Cryptomator with and without the Dokan drivers a couple of times, but that didn’t help.

The new computer runs Windows 10 (1909), I have no Antivirus software installed apart from the Security Essentials that come with Windows itself.

What else can I do to get the program to run or at least show me any kind of error message?

I just found the place where Cryptomator stores it’s logfiles and it’s telling me “java.lang.RuntimeException: No toolkit found”.

Doesn’t Cryptomator install everything it needs to run?

Yes it imstalls its own JVM.
Maybe something went wrong during the installation. Have you tried to uninstall Cryptomator and install it again?

Cryptomator uses the JavaFx library to show the user interface. To see if JavaFx supports your system, there exists a small test application:

Download the respective zip-archive for your system, unpack it to a directory of your choice and start it by double clicking the launcher-win.bat file in that directory. You should see the following window:

Little side note:

Reminded of this: :smiley:

1 Like

@Michael: I installed it several times, but without uninstalling it before. Will try to uninstall it before the next installation attempt.

@infeo: Will try that tomorrow. What would I have to do/install to make it run, in case it doesn’t run?

Any chance the new machine has an ARM CPU?

@overheadhunter: No, it’s a plain (not so) old Core i7 from Intel.

@Michael: Uninstalling it before reinstalling didn’t change a thing. Still not working.

@infeo: Your test program opens something that looks like a console, a lot of lines are running through very fast, then it’s closing again. No test window opens and no error is shown either (at least not in way I could capture).

That was also my first thought. But since you say it is a “normal” desktop CPU, this can be ruled out.
What architecture (x86 or x64)?

To get the console output, you can do the following assuming you unzipped the archive to .\Documents\javafx-testkit-windows:

  1. open the terminal by entering cmd into the windows search bar
  2. navigate to the unzipped folder: Enter cd Documents\javafx-testkit-windows\
  3. execute the .bat-file: .\launcher-win.bat

Copy the content of the console and paste it here.

Maybe edit the launcher-win.bat file and add -Dprism.verbose=true ^ to get more detailed logs from the UI toolkit:

@echo off
@echo off
SET path=%~dp0
"%path%runtime\bin\java.exe" ^
    -Dprism.verbose=true ^
    -m de.skymatic.javafxtest/de.skymatic.javafxtest.App

@infeo: It’s a 64 bit chip with a 64 bit operating system (Windows 10 Professional).

I think I found the problem, but I don’t know a solution. Starting your test program I get 100kB worth of error messages of the type:

Loading library <library name> from resource failed: java.lang.UnsatisfiedLinkError: <path to library>: Can't find dependent libraries

The problem seems to be that my username contains umlauts, but these umlauts are missing in the <path to library> of the error message.
But that can’t be a general problem because I use user names with umlauts on at least another computer as well, and there Cryptomator works.

I also found the solution. I don’t know why, but it seems that Dell totally f*cked up the Windows they install. When I opened up a console and typed “chcp” it showed codepage 65000, not the codepage 850 common in germany. A lot of language settings you can find all over Windows were half set to german and half set to english.

To get Cryptomator running again, I had to change some codepages in the registry.

If you know what you are doing then open the registry editor (totally your responsibility), go to


and change the following values to values that you should get from a computer that’s working fine in your language of choice. For my language german that were the following values:

  • ACP => 1252
  • MACCP => 10000
  • OEMCP => 850

The OEMCP value seems to be the one setting the codepage for the console.