Cryptomator crashes after deleting at least 1.4 GB of files


I was able to reproduce this on two external HDDs and two cloud service providers.

What software is involved?

OS: Linux Mint 21.1 Cinnamon
Cryptomator 1.7.3 (appimage-4367)

Volume Type:


Steps to Reproduce:

  1. Mount Cryptomator.
  2. Delete files (They go to Linux Mint’s Trash folder.)
  3. Delete same files from Mint’s Trash folder.
  4. Crash.

Expected Behavior:

No crashing.

Actual Behavior:

  1. App freezes for about 15 seconds and then it crashes.
  2. When trying to mount again, Error N05M:GEAO:GEAO appears but this would be solved by running fusermount3 -u dir as in this thread.


For at least 1.4 GB of files in my case (or 10,000+ Cryptomator files).
2.9 GB is the highest I experienced this is at.

Anything else?

Didn’t have this issue with previous versions of Cryptomator. I just updated to the latest version today.

Thank you.

1 Like

I’ve been having the same issue on both my laptop and desktop machines - both Ubuntu 22.04. Cryptomator recently started crashing as soon as I start operating on multiple files at once (e.g. recursive delete on a not so big folder - it took me 3-4 tries - each try ending with a fusermount3 -u, till I finally succeeded).

This is definitely a recent issue.

Just a note to self. Seems replies are faster over at Github for this kind of issue. (Can’t post the link but I posted an identical issue there.)

Have you found any workaround?

Issue on my end seems to be getting worse.

Have you tried deleting everything and creating a new vault? I’m now planning this but might do it next week.

BTW, I’m now on version 1.7.5 (appimage-4400).

Can I try out other volume types? I can see Automatic, WebDAV (gio), and WebDAV (HTTP Address).