Cryptomator broken in Files App on iOS & iPadOS 15.3

Cryptomator is no longer usable on my iPhone and iPad (both on 15.3 version of the OS): it keeps asking for Authentication in the Files App but when I authenticate (successfully) it comes back endlessly with the same message that Authentication is required (see screenshot in Dutch). Something is really broken! Anyone has a clue? Fortunately I am still able to access my files via the Mac (running macOS Monterey 12.1).

Could you please send the log file to You can access them via the settings in Cryptomator. Or you can check them out yourself and post the error message that is logged there.

Logfile (as a zip-file) has been sent to, thank you!

Quick question: After unlocking the vault, what happens if you go “back” (“blader” at the top left) and then return to the Cryptomator vault. Do you still see the error after that?

I know, it sounds like a weird workaround but there is actually a bug that we’re fixing with the next update 2.1.1 that might be related to that. If not, then it’s something else and we’ll keep investigating.

I would have been perfectly happy with this workaround but I tried it immediately (so unlocking the vault, go back (“blader”) and return to the Cryptomator vault) and unfortunately it did not help. Same screen appears again, asking endlessly for authentication. I tried unlocking with both password and Face ID (in both cases the unlocking is successful) but this made no difference when returning to the Cryptomator vault.

We’re still looking into it and scratching our heads what the cause might be. In the meantime, did you already try to remove the vault from the list and re-add it?

We believe that it might be crashing (which are unfortunately not logged via “our” log file). Could you please go to iOS Settings > Privacy > Analytics & Improvements > Analytics Data and search for “cryptomator” (or maybe “org.cryptomator”)?

If there is actually something there and it’s also recent, would it be possible for you to share the crash log?

I tried indeed removing the vault and re-adding it. Did not help. Tried it again today. Same result, did not work.

I checked this and nothing from “cryptomator” (or “org.cryptomator”) in the iOS Settings > Privacy > Analytics & Improvements > Analytics Data
The latest data in the Analytics Data dated from 17-10-2021
It seems to become a nasty problem. Could of course also be related to iOS 15.3 or a recent update of OneDrive. All apps are updated to the latest version and problem persists. Just let me know if I can do anything else to help.

I was told that you have to look for “FileProviderExtension”. Apparently, “cryptomator” is not part of the name. :sweat_smile:

We were both looking at the wrong places: I thought that my most recent Analytics Data dated from 17-10-2021 but I was wrong :sweat_smile:
In fact, I found the “FileProviderExtension” data (dated today) and have sent it as an .ips file to
Crossing my fingers!

1 Like

That was very helpful! It took me some time to re-symbolicate the crash log but here it is:

Thread 0 name:   Dispatch queue:
Thread 0 Crashed:
0   FileProviderExtension         	       0x10075ed70 specialized Cryptor.calculateCleartextSize(_:) + 1142128 (Cryptor.swift:339)
1   FileProviderExtension         	       0x10075dd6c Cryptor.calculateCleartextSize(_:) + 1138028 (<compiler-generated>:0)
2   FileProviderExtension         	       0x10075dd6c Cryptor.calculateCleartextSize(_:) + 1138028 (<compiler-generated>:0)
3   FileProviderExtension         	       0x1007096dc VaultFormat7ProviderDecorator.toCleartextSize(_:itemType:) + 792284 (VaultFormat7ProviderDecorator.swift:263)
4   FileProviderExtension         	       0x100709514 VaultFormat7ProviderDecorator.toCleartextMetadata(_:cleartextParentPath:parentDirId:) + 791828 (VaultFormat7ProviderDecorator.swift:254)
5   FileProviderExtension         	       0x10070c244 specialized Sequence.compactMap<A>(_:) + 803396 (VaultFormat7ProviderDecorator.swift:270)
6   FileProviderExtension         	       0x100707404 closure #3 in VaultFormat7ProviderDecorator.fetchItemList(forFolderAt:withPageToken:) + 783364 (VaultFormat7ProviderDecorator.swift:0)
7   FileProviderExtension         	       0x10070c04c partial apply for closure #3 in VaultFormat7ProviderDecorator.fetchItemList(forFolderAt:withPageToken:) + 802892 (<compiler-generated>:0)
8   FileProviderExtension         	       0x10070c07c partial apply for thunk for @escaping @callee_guaranteed (@guaranteed CloudItemList, @guaranteed Data) -> (@owned CloudItemList, @error @owned Error) + 802940 (<compiler-generated>:0)
9   FileProviderExtension         	       0x100f35658 closure #1 in Promise.then<A>(on:_:) + 9360984 (Promise+Then.swift:0)
10  FileProviderExtension         	       0x100f35324 thunk for @escaping @callee_guaranteed (@guaranteed Swift.AnyObject?) -> (@out Any?) + 9360164 (<compiler-generated>:0)
11  FileProviderExtension         	       0x100f4171c __56-[FBLPromise chainOnQueue:chainedFulfill:chainedReject:]_block_invoke.67 + 9410332 (FBLPromise.m:0)

It’s a little technical but it crashes here: cryptolib-swift/Cryptor.swift#L339

From my understanding, this can only happen if Cryptomator receives negative file sizes. I have no idea why there would be negative file sizes in OneDrive. But this information alone helps a lot and we should be able to come up with a fix that I’ll schedule for the upcoming 2.1.1 update.

Thank you for reporting this issue!

1 Like

You’ve made my day!! I deleted a suspicious file of 0KB size and now everything works again like a charm! Fixing it in an update would be nice of course (for other users as well) but at least the cause has been clarified now and finding and deleting the suspicious file gives a good workaround. Many thanks!!

Awesome, happy to help! Good to know that it was 0 KB, then I won’t have to track down negative file sizes anymore. :laughing: It makes sense though, just looked through the code again. “Ciphertext” file sizes smaller than 88 bytes are problematic. We’ll find a fix for that. :grin:

1 Like