Cryptomator android app requires a root folder selected to add vault to the vault over webdav

Good day, i had to change the URL to access to my cryptomator database recently so i had to delete the vault on android, then edit Webdav URL, and then i try to add the same vault back, when i click on the masterkey file get a message:

“Please select a top/upstream folder of the vault you want to add”

I can not do it as the cryptomator database is at very root of my directory scructure, to make it happen i need to create a folder, copy all the vaul files into that, reconfigure all other clients as besides cryptomator i use nextcloud to synchronise files, i can do it but its not fast.
I dont remember any issues before on that matter, something has changed that cryptomator mobile app requires that vault is not at the root folder ?
Thank you

Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

Since the last update we show a meaningful message before you can add this vault with a hint what the problem is and how to solve it. Before this version you could add the vault but it had an empty name and when trying to open it a “Vault not found” dialog was shown. So something has changed but only regarding the display of this state, using a vault in root was never possible.

Did you moved the d folder, the masterkey.cryptomator and vault.cryptomator file out of the vault folder? Because if not, you should be able to add the root of your Nextcloud as WebDAV connection https://DOMAIN/remote.php/webdav/ and then this vault isn’t the root anymore. So please check if those files are laying around in the root of your Nextcloud folder and if not, check the added WebDAV URL in Cryptomator for Android and if you added a deeper path than the root, just remove those path segments to the above mentioned scheme.

Hello, first, thank you for the reply, lets see the my current configuration, as per nextcloud webdav url is looking like this:

example.com/nextcloud/remote.php/dav/files/USERNAME/

my old url which worked was this (i dont use nextcloud subdomain as its only site i have

https://nextcloud.3-a.net/remote.php/dav/files/myuser

After URL change nextcloud is working fine on new url, and nextcloud clients are OK both for mobile and desktop.

I have deleted the vault in cryptomator android application, and edited the URL to this form
https://nextcloudnew.gq/remote.php/dav/files/myuser

The filles in nextcloud have not been moved, or anything, and the old URL worked fine with android application

When webdav opens the URL it gives this directory structure (the root ot nextcloud):

This is where it complains when i select the cryptomator vaul key

The vault name was empty i think, but i allways was able to open it and use it.

So the only solution i have is to create a cryptomator directory and move everything there ?

I would like to answer to my question, i have moved the root folder, and i was able to add the vault in aplication, so everything is fine, i have no idea how it worked before, as yes i understand now the name was empty, and i was thinking that it is normal, but i could use it without any issue whatsoever :wink:
Cheers

1 Like

I am very surprised that the vault could be opened on your device, but the main thing is that it works again, thanks for sharing :slightly_smiling_face:

© 2021 Skymatic GmbH • Privacy PolicyImpressum