Cryptomator 2 can’t open vaults created by Cryptomator 1

Hi, I’m a long-time user of Cryptomator iOS app and just upgraded to 2. However the latest app seems having compatibility issues with old version vaults. I have one vault on OneDrive and another on iCloud. Neither would open.

Yes, you need to upgrade your vaults to Vault Format 8 to use them with cryptomator 2 mobile apps.
To do this, open your vaults with cryptomator desktop and the migration will start.

Cryptomator 2 is actually also compatible with vault formats 6 and 7. That means, your vault format is anything between 3 and 5, which is indeed quite old (5-6 years). Could you please check the version numbers in the masterkey.cryptomator files? You can open them with any text editor.

  • If it’s vault format 5, you can actually use the latest Cryptomator version and proceed with the upgrade.
  • If it’s below that, you have to use Cryptomator 1.4.x to upgrade to vault format 6 first. (1.4.17 for macOS or 1.4.15 for Windows/Linux)

Sorry, wasn’t aware of that. :smile:

1 Like

Thanks for the timely help.

I’ve found out one vault is “version” : 5, another is “version” : 4. However I still can’t open that version 5 vault even after I updated to the latest 2.2.4

Sorry, I meant vault format 5 can be migrated by the latest Desktop version of Cryptomator. The iOS version can only open vault format 6 and onwards.

Alright. I’ve downloaded desktop versions 1.4.x according to your instruction. But now when I try to upgrade a version 4 vault, it says “could not authenticate MAC”. I’ve tried on both Mac and Windows versions. Same result.

Oh boy, way back then we had an implementation error in the iOS app that could not be “automatically” fixed.

This is a similar case: Upgrade version 3 to 4 fails - #2 by tobihagemann

All the steps are the same, except in the last step, you can then use 1.4.x to proceed with the upgrade.

It finally works. Thank you for the help!
The new way of accessing files in Files app, still getting used to. So, instead of using 1 app we now have to use 2 apps… I don’t know. Maybe other people like this way… The thing is, to me, you can’t lock the vault manually in Files app after it’s unlocked, that’s the catch.

You can lock the vault in the cryptomator app manually

Yes, of course. You don’t think it’s a bit of hassle?

Can you guys make unlocked vaults automatically locked whenever we manually killed the File app? That way it’ll do almost as good a job as a ‘Lock button’ in File app, but much simpler to implement I suppose…

This doesn’t work because the Files app is a different process than the so-called File Provider Extensions. There is no way to “terminate” such an extension, the life cycle is controlled by iOS. That’s why there is this unlock duration option “Let iOS Decide Automatically”:

There actually is one way, where we could offer a “lock vault” option inside the Files app. We can add “custom actions” to files/folders. We thought that it’s kind of weird that you have to long-press a file or folder in order to lock the vault. But maybe it’s a workaround that we should implement anyway.