cryptomator-1.7.1-x86_64.AppImage seems broken on my chromebook linux

I’m using the cryptomator app image in the linux debian 11 (bullseye) container of my chromebook (ChromeOS 110.0.5481.181 64 bit stable channel, developer mode = false). I place the appimage into the directory ~/Applications (where ~ is my user home directory).

In the older version cryptomator-1.6.17-x86_64.AppImage and before, opening the vault resulted in the decrypted files becoming visible at ~/.local/share/Cryptomator/mnt/XXXX where XXXX is the vaultname.

In the newer version cryptomator-1.7.1-x86_64.AppImage , the program launches and initially acts the same, but only up to a certain point. Specifically, I can unlock my vault and the padlock icon shows open. BUT nothing appears in ~/.local/share/Cryptomator/mnt/ and the files do not appear accessible to me anywhere.

EDIT - The older version was using FUSE. The newer version changed itself to webdav and doesn’t show FUSE as an option anymore.

EDIT2 - As far as I can tell webdav tries to do something involving localhost. I tried to paste localhost address into the browser within my linux container, but no luck. I’m pretty sure chromeOS does some behind the scenes controls related to localhost and rerouting of internet connections to the linux container as part of their security model. So my belief is that the chromeOS routing of internet connections is getting in the way of the low-level connection routing that cryptomator is trying to do with webdav. But I have to admit i’m far out of my depth… I don’t know anything about networking and “localhost” and things like that.

I got a response from a pretty knowledgeable user on reddit

TLDR: with the 1.7.0 release Cryptomator changed their FUSE implimentation to JFUSE and the new API fails to mount a previously working vault. Stick with 1.6.17. See important update below.

I was intrigued by OP’s dilemma so I created a test vault using the 1.6.17 AppImage. After multiple attempts to mount the test vault in 1.7.1 failed I checked the Cryptomator github for clues and found that the FUSE implimentation changed in 1.7.0 from FUSE2 to JFUSE. Details here and here.

Despite updating FUSE in the Crostini container (sudo apt install libfuse3-3) and adding support for JFUSE (sudo apt install libc6-dev-amd64-cross) the 1.7.1 AppImage still failed to mount the vault. A review of the log file showed the cause being failure of the JFUSE API. BTW, I tried moving the contents of my test vault to a new vault created in 1.7.1 but even that failed due to the JFUSE API issue. Unless/until this is resolved I’d say it is safest to stick with 1.6.17.

From the log file:

Caused by: org.cryptomator.jfuse.api.FuseMountFailedException: fuse_mount failed

UPDATE: by starting with a fresh Crostini container I found the Cryptomator 1.7.1 AppImage was able to unlock and mount the previously (in 1.6.17) working test vault. This was achieved after updating/upgrading the new container then running sudo apt install fuse3. This replaced the entire FUSE2 environment, its libraries and dependencies, with a clean FUSE3 environment. After rebooting the container the 1.7.1 AppImage successfully unlocked, mounted and, importantly, re-locked the vault without errors. My conclusion, to successfully replace the existing FUSE2 environment currently installed in existing Debian Bullseye systems with the FUSE3 environment capable of running the 1.7.1 AppImage is not going to be easy.

So the TLDR on my last post was that the recent update of cryptomator appears to use a newer version of Fuse (Fuse 3) which is NOT supported on Linux Debian stable 11.0/Bullseye (which is the default OS used in the Linux LXC container of chromebooks… and also widely used in the linux world outside of chromebooks)

At least that’s the way I understand it. Does anyone agree or disagree?

Does anyone have suggestsions for how to use webdav on a chromebook? (i don’t see any files, all i see is a numeric localhost address which doesn’t do anything when i put it in my browser)

Or do I just have to stay on the older version of cryptomator until Debian gets support for the newer fuse or cyrptomator decides to restore copmatibility with older versions of fuse?

Fuse3 should be available on bullseye, see Debian -- Details of package fuse3 in bullseye

1 Like

ok, you’re right. i guess i didn’t read the other reply close enough (I focused on the last line where he said it wasn’t going to be easy. )

The following fixed it

  • sudo apt update
  • sudo apt install fuse3
  • i restarted the linux container
  • i started cryptomator 1.7 appimage and switched back to fuse… it works fine.

thanks for pointing me in the right direction.


Awesome, I’m glad it works now :slight_smile:

1 Like