Cryptomator 1.6.5 for Windows 10 & Dokany 2.0.0.2000

Hi, I updated Dokany to 2.0.0.2000, but it is not working with Cryptomator 1.6.5. (only offering WebDAV, not Dokany). After deinstalling/ reinstalling Cryptomator and Dokany several times in various orders I went back to Dokany 1.5.1.1000. Now Cryptomator offers WebDAV and Dokany again. Any idea why Dokany 2.0.0.2000 is not working with Cryptomator 1.6.5?
Regards, Matthim

Welcome to teh Cryptomator Communtiy :slightly_smiling_face: ,

this is a known issue, see https://github.com/cryptomator/cryptomator/issues/2001.

In short:
Dokany introduced with version 2.x major, breaking changes, which are not compatible with prior Dokany versions. Cryptomator currently only supports Dokany 1.x .

1 Like

Many thanks.
Do you have experiences with WinFSP? Would you recommend to switch from Dokany to WinFSP?

I tried WinFSP, but it has issues. For example, if you use OneNote and save Notebooks in the vault of Cryptomator, pages in the notebooks saves incorrect or with errors. With Dokany 1.5 it is not happened.
I’ll wait when Crypotmator add support Dokany 2.0.

Any updates on this issue?

I have noticed, that Dokany published a new update meanwhile. They are now at 2.0.2.

Unfortunately, the alternatives do not really work for me. Using WebDAV brakes MindManager, WinFSP still has issues while using AzureAD as sign-in to the workstation. :frowning:

Yep, Dokany 2.0.3.2 now.
Another issue WinFSP has is with SyncBackSE (that I use for auto-syncing + versioning), where tasks just start and stop right after. I don’t have the time (or the knowledge) to try and find out why so I guess I’m sticking with Dokany 1.5.1 too.
In the meantime, thanks for letting us know why Donaky 2.x doesn’t work at the moment.

Dokany to 2… Any news?

© 2022 Skymatic GmbH • Privacy PolicyImpressum