Cryptomator 1.5.6. with pcloud 3.9.3. unbearably slow

Cryptomator 1.5.6
Virtual Drive Type: FUSE
macos 10.15.5
pcloud 3.9.3 (PREMIUM 500GB)

Browsing my encrypted files in the Finder is very slow:

  • 1-4 MB pictures take about 30secs to be previewed
  • opening a directory full of pictures takes minutes before the content is displayed
  • selecting and moving batches of files (15+) is hardly doable and lets Finder crash very often

Also Cryptomator crashes regularly so that locking and quitting will do nothing and I have to force quit the application via the Activity Monitor.

Might pcloud be the reason since they try to push their own crypto solution?

I’m wasting a lot of time here so your answer is very welcome. Thank you!

Pcloud is working well for me- very good performance browsing folders. Even when their service is running slow, the local cache makes browsing and regular files almost as fast as a local hard disk. ( i dont use a mac though)

Theres been a few client updates recently… Is Pcloud currently working ok outside of cryptomator for you? (try a folder of unencrypted photos)

Are you working on their virtual drive directly, or using a sync folder?

Thank you. It’s good to read that pcloud works well for you.
Outside of Cryptomator it seems to be working fine here as well.

I realized that, in pcloud, my disk usage settings were at the minimum, so I changed that to 10 GB for the Minimum Disk Space and to 70 GB for the On Disk Cache Size. There’s not much more left on my laptop.

I’m using the virtual drive directly and did not move all my data to a sync folder.
Would you recommend that?

I’ll see how it works from here and will report back.

Use the virtual drive directly (I always do). Especially since you are low on space, Sync folders would keep a copy locally…

Did you have any issues with older versions of cryptomator? I see another mac user has posted issues today with 1.5.6, but was fine with 1.5.5


Increasing the minimum disk space and Cache Size in pcloud solved it for me – so no problem with Cryptomator, just a pcloud setting.

Thanks! Sorry for taking so long to get back.