Cryotomator forces the entire vault to download on the local drive


The issue I’ve been having with trying it on multiple machines is that cryotomator forces the entire vault to download on the local drive so if you have a TB Of data you want to access a few files from, it becomes impossible. On phones they allow read only or selective downloads but on desktop it’s forced, would be nice if you could pick what stays in cold storage on a cloud vs what needs to stay synced.

I tried crypto duck and it only gives me problems. Endless errors trying to upload files into its folders, it crashes and freezes endlessly. I also can’t access even text files from it without it giving me file not found errors so it’s not trustworthy in my opinion… Unless I’m doing something very wrong on it.

Cryptomator, shouldn’t have anything to do with your synchronization settings because it itself does not participate in that directly.

What type of cloud storage are you having problems with and what software are you using to synchronize the data back and forth because I don’t sync the data down to my computer I leave it on the cloud and access it as a remote Drive and I have several terabytes of data across several cloud services and nothing ever gets downloaded other than the individual file that I choose to click on.

We need to look at the relationship between the software and how your implementing The Vault and synchronization.

I moved this to a new topic because of this rule:

This is how cryptomator desktop is designed.
In order to work with as many as possible storages, the sync (and thus the connection) process is done by the storage provider tool.
The mobile apps, on the other hand, are designed to minimise data consumption (transfer and device). This is why they connect directly, but are not compatible with all providers.

If you have problems using cyberduck, the only other idea I have is to use the file-on-demand function of your storage provider to reduce HD space consumption. (Provided that the used sync client does offer this function)

Personally, I mount my cloud storage providers with a program called Rclone.

Then I tell cryptomator that the vault is located at the locally mounted directory for the specific remote Cloud Drive.

Unlocking The Vault and choosing to access one file does not trigger the download of any files other than the one that I choose.

That’s why I was asking what technology you are using to access your files on the Cloud Drive and how you have synchronization settings configured.

The software that you’re using for synchronization may be the cause of the problem not cryptamator.

Rclone can be a little tricky at first to learn so I would be more than happy to assist you if you would like to give it a try. It’s open source and works on Mac Linux and windows. It’s a command line utility and you run the configuration this way:

rclone config

I actually do use rclone on my Linux machine and it works decently although it’s a bit slow. The problem isn’t my pCloud downloading, it actually doesn’t to my knowledge. It’s cryptomator that forces the unecrypted vault to be in a local drive so all of the clouds encrypted data is duplicated on the machine. That’s why Michael suggests Cyberduck, it’s a clone of cryptomator but doesn’t need local duplication. But Cyberduck just doesn’t work well at all, I get nothing but errors and bugs, freezing etc when trying to copy or extract files.

I will do some testing and see if I can come up with a solution that will work for you.

Have you compared using the pcloud software for Linux to mount your pcloud drive versus using rclone to mount the Cloud Drive?

I’m trying to confirm for myself that when using rclone, the entire Vault does not get unencrypted and downloaded each time you open the vault.

When I mount the pcloud drive with rclone I am choosing to mount the folder that has the encrypted vault in it and then when I run cryptometer I link it to a folder in my home drive.

I have put several gigabytes of data into a test Vault that I created for this situation and so far I can’t see any evidence that simply mounting the Vault causes gigabytes of data to suddenly transfer down to my computer. I can see the files but I don’t actually download 5 to 10 GB of data just because I opened the vault.

I’m doing this using a Chromebook with Linux enabled and I’m using the Linux version of pCloud Drive and rclone and cryptomator.

In my file explorer I can see the files that are in the vault and available for me to use only the free space that it shows in file manager is the available free space that I have on my pcloud drive not my local PC.

I will post a picture.


You’re saying to not use the pCloud Drive app because it will force the non-encrypted vault to duplicate, and only use Rsync instead? Even Michael says that you MUST have the unlockable vault in your local drive for Cryptomator to work, and if you don’t want to have one copy locally and an encrypted copy on your cloud, then you must use something like Cyberduck or file-on-demand such as webdev instead.

I believe the way Cryptomator works is, you select a path where you want the encrypted folder to go, but then Cryptomator automatically chooses a path on your local drive to have the unlockable vault, for which there is no getting around. This is how it works on my Linux setup anyways.

If I mount my pCloud via Rsync, Cryptomator will allow me to setup the encrypted vault within that mounted drive, but it will still create the unlockable vault in my local drive.


I can tell you for certain that I have way more data on my server than I have available space on my local computer. It’s not full, but it is a 4 TB cloud drive. By the way the software does let you choose where you mount the local vault. The default is for it to pick the location for you but you can override it. See pic.

In the example I am showing you in this picture it is with Rclone mounting the pcloud drive, not the pcloud software.

Rclone won’t transfer anything to your PC until you actually click on it.

If you would like to test it out, I can help you get it configured if you have questions. It is a simple command line utility that runs on Windows Mac and Linux.

You run “rclone config” to get started.

Then, to mount the drive:
rclone --vfs-cache-mode full mount pcloud: q:

It can be a little intimidating at first so don’t feel hesitant to ask a question.

Sorry, I meant Rclone not Rsync. It’s not the mounted cloud that takes up space, that is, pCloud Drive or pCloud mounted via Rclone. It’s the local unlockable vault location that takes up local storage, and I cannot pick where Cryptomator puts that folder, otherwise I might choose a large USB drive. I do encrypt virtually my entire cloud.

I could make several vaults for my cloud, but every time i put items in those vaults, they will remain in my local drive. I suppose I could load up the vaults i use more for cold storage, then delete those local vaults from my system. But I honestly don’t know how these local vaults dont take up space, or how you can keep the local vaults virtual or strictly cloud based.

Where did you originally create the vault? Did you create the vault on your C drive and sync it to your P cloud or did you create it originally on the P cloud?

The amount of local storage space used by a vault depends on where you create it and how you sync it with your online storage. If you create a vault on your local drive (C:), then it will use the same amount of space as the original files. If you create a vault on your NAS, then it will use the space on your NAS, not on your local drive. If you create a vault on your online storage provider, such as Google Drive, then it will use the space on your online storage, not on your local drive.

I have maybe 35 GB free on my C: drive and hundreds of gigabytes in one vault.

I do not keep any vault files on my PC. When I created the vault I created it on P cloud not on my local PC and I did not sync it to the cloud or back it up to the cloud.

When I unlock the vault and click on reveal it opens up to f: on my PC, showing me the unencrypted names of hundreds of gigabytes of files and none of them are actually on my PC at that time. My computer will still have all 35 gigabytes of free space.

Just like the files that are on P: are not really local to your computer even though they’re assigned a local drive letter.

My F: drive which is the unlocked unencrypted version of my vault That shows all 500 gigabytes of data is not really on my PC, and it doesn’t sync to my PC.

ONLY when I click on one of those files does it actually transfer from P Cloud down to my computer.

This is true even if you use the pcloud software to connect to your cloud drive.

This attached picture is from my Chromebook which has barely no space at all on the local disk. I’m using the flat pack version of kryptonator for Linux.

It’s basically showing that I have 4 terabytes of free space on my chromebook which we know is false.

For me, Cryptomator doesn’t work like that. When I make a new vault, I put it inside my pCloud or my G Drive for example. None of my cloud drives take up local space by the way. There is then a local vault that is accessible and unlockable, that’s automatically placed in my /home/admin/.local/share/cryptomator/mnt folder. I cannot select where I want this folder to go, nor if i want to keep it only where the encrypted vault goes.

According to Michael, cryptomator MUST place a local vault because that is where your non-encrypted files may be accessed, and if i want to only use a virtual cloud-based vault, I must use something like Cyberduck as that’s how it works, but it’s too glitchy for me.

How are you able to reveal the vault for which you created? That vault is permanently encrypted for me, and only its local /home vault is revealable.

You can read the file names because the vault was unlocked, and that directory is where Cryptomator chose to put the unlocked folder. I just attached another picture with the unlocked vault in a folder of my choosing. Now they are mounted in /home/leow/hwmpunk.

You can choose exactly what folder you mount your unencrypted vault to. You might be able to choose an attached USB drive, I haven’t tried.

The list of files that you are looking at in that picture are the actual files however they are not on my PC yet they are still in the cloud. They don’t actually land on my computer until I click on one and open it. That folder is the designated folder where they do go when I choose to open one. When I click on the file P cloud will download the file to my computer.

I just created a folder in my home with your user id. With the vault locked, click on “Vault Options” in the lower right corner of the app.


I do not have the same options as you. This is what I see on my Cryptomator:

Ideally I have my vault in my Cloud, and I’d also like the unencrypted version of it in my cloud as well. But when I make a new Vault, I do not have an option for where to mount the accessible Vault, only where the encrypted Vault will go.


How is it you have an option to mount where to put the unlocked folder and I don’t? I believe you are on Linux as well, no? I install Cryptomator using a yay command to install cryptomator-bin so I’m assuming Cryptomator keeps their repository version updated.


I’m at work now but when I get home I will look and provide you is either instructions or a picture. I use both windows and Linux so I don’t recall which one I was using when I mentioned that to you I will check in a bit and get back to you.

Because you are looking at the wrong setting tab.
@LeoW’s Screenshot shows the vault specific settings (right click on vault, vault oprions).
Your screenshot shows the general app settings.

1 Like


the picture that you posted is from the settings page. You must have clicked on the little gear icon after you launched the app. Wrong place.

  1. Open the application. Your vaults will be listed in a column on the left.
  2. Highlight the vault or select the vault that you would like to modify the
    location of the mount point.
  3. In the lower right-hand corner of the window, click on “Vault
  4. Select the middle tab, called “Mounting”.
  5. Select “use chosen directory
  6. Click/select the “Choose” button and navigate to where you want
    the mount point to be.

See attached picture, and look more closely at the first one I posted.
The first button you want to click is on the main window right after opening the app.

Hope this works for you.

1 Like