CPU usage (again, but much worse now)

I need to come back to this topic. I run the latest version 1.4.15 on Windows 10/64 with all updates installed. I use WebDav as Dokany cannot sync with FreeFileSync (or the other way round).

Even if absolutely nothing is done by Cryptomator, it used around 50 (fifty!) % of all CPU on a high powered workstation with mighty processors.

What is happening? What can I do?

Thanxx, Mixx

Hi Mixx,

I tried to reproduce that and did this test again with a fresh 1.4.15 /WebDAV installation on a really bad equipped win10pro/64 notebook (i5-4310M, 8RAM)

The result was the same… My CPU Usage with this cryptomator version was nearly permanently 0% within my 1 minute staring at the task manager (now and then there was a 0.x% “peak”). Vault was open.

So, unfortunately I cannot reproduce this and please excuse for asking: are you sure that no other process is accessing the files in your vault, or your vault?

Do you have a maleware protection software installed? It may be possible that it scans this drive, causing a high cpu usage.

Side remark: Since version 1.4.15 you can use Dokany with FreeFileSync, see Mounted Drives hidden from sync program.

NO, I am not sure at all. How would I go about and determine that (that no other process is accessing the files)?

Thanxx, Mixx

I switched to Dokany to see what happens.

Same thing, between 45-50% of CPU.

My Vault is only 1.5GB. If this was a virus checker, it would have to be done after a few hours. Again, this is a workstation, not a PC.

Is there a way to find out, what Cryptomator is doing with that immense computation?

Thanxx, Mixx

Well, I would open my task manager an kill every program/process (except Cryptomator and of course system) that does consume resources or is not really needed. Step by step and always have a look at the Cryptomator usage.
When it suddenly drops, you likely have your app detected.
Most often these are (like @infeo already mentioned): malware protection, anti virus, indexing apps, backup processes, sync processes.

Please don’t get me wrong: I’m not saying that you doesn’t need malware protection or antivirus. But there are good ones and there are bad ones. So besides it’s function you can identify the app by excluding them.

1 Like

For the technical inclined there is also a less aggressive approach: The programm Handle from the Windows SysInternals Suite can list all processes which operate on a specific directory.

2 Likes

Sorry, I was away.

Thank you infeo, I installed “handle” and found out that indeed one of my Cloud Sync applications (for pCloud) is actually accessing the (encrypted) vault.

It is another matter, why pCloud is doing that for so long. I’ll clarify with pcloud.

But what you might be able to help with: why is that a problem for Cryptomator? Afterall. Pcloud is uploading only (in my setup). I never change the files in the Vault anywhere else.
So why is that such a challenge for Cryptomator? The files do not change!

Also: I just discovered: even if I stop pCloud sync (exit the app, nothing shown in Task Manager), Cryptomator carries on computing (60% of CPU). Now nothing (!) accesses the Vault (as reported by Handle). Still 60%.

Thanxx, Mixx

I am apparently unable to generate interest. But this situation is just carries on 45-60% CPU usage by Cryptomator, even though no matching handles on the Vault, no access to it by anything I can establish. At any rate, there are no changes to the Vault either, so there is nothing to process.

Anyone, please?

Thanxx, Mixx

I really would like to help, but I cannot reproduce this. I have cryptomator installed on 3 machines now, from high performance PC to an outdated notebook. No matter if I use dokany or webdav, mounted drives or not, sync active or not. If I do not touch the files inside a vault cryptomator app does not use the CPU (see above).
So I’m afraid I’m out of support here. Maybe someone else has an Idea.

I once had the strange case that Handle could not list all handles. (see here)

Just to exclude this possiblity, do the following:

  1. Download ProcessExplorer,
  2. start it with admin rights
  3. Open your vault, mount it with Dokany
  4. In Process Explorer, open over the “Find”-Tab “Find Handle or DLL…”.
  5. Enter Path to your vault access point (e.g. Z:\)