Corrupted vault folder and files structure


I had been storing vault on iCloud Drive. At some point vault size grew larger than my Macs SSD size, therefore I wasn’t able to store full version locally.
Recently, I had issue with Mac version that it wouldn’t display folder structure at all (both with FUSE and webdav). Therefore I tried to use health check and fix issues, but forgot to download vault fully.
Which in the end resulted in corrupting folder and files structure.
What I tried it to download vault fully to external drive and run health check again.
Currently, on Mac and iOS (which previously worked without issues) I can only see top level folder + LOST&FOUND folder.
None of the folder have any files, except for LOST&FOUND. But even there I don’t see any of my files after mounting.
on iOS trying to browse folders shows “Content Unavailable” message.

Is there any way to restore folder/files structure? Or somehow else restore my files?

When I check vault size it still shows up as original size, so I presume files are there.

What was the result of this health check?

Bunch of errors with folder structure. I went through all of them and pressed fixed. It helped restore top folder structure, but files aren’t there.

There are some files in LOST&FOUND - around 20ish GB out of 400 Gb. I used this script Sanitizer: Restore Missing File Extensions to restore file extensions, and it did. But again, it’s only 20Gb out of 400 Gb.
Is there a way to decrypt files without folder structure?

Got it.

@SailReal will be able to help you better.

@SailReal please help :slight_smile: