Corrupted/missing folders within vault

os:windows
os:android

#1

I currently use Resilio Sync to sync vaults between my devices.
in Windows 10 using Cryptomator 1.3.3 I cant see a couple of folders in my vault.
switching to Android (paid and updated version), i can see the missing folders, but i get “an errored” if trying to acces them.
any ideas? willing to send logs


Ghost directories when syncing with Resilio Sync
#2

Please start Cryptomator, unlock the affected vault and navigate to the parent folder of one of the missing folders. Then lock and quit Cryptomator.

The most recent log file should now contain exactly what is needed to analyze this and nothing more.

Then send an email to the support team.


#3

Is it safe to use Resilio Sunc with Cryptomator?


#4

OT, but I’ll answer this anyway…
Yes, my missing files was most probably caused by exposing the vault via webdav where my dav-server didn’t properly manage all file-operations.

So compatibility between resilio sync and cryptomator shouldn’t be an issue, it’s still a file only its encrypted, resilio doesn’t care. I’m referring to syncing the encrypted files now, not an opened cryptomator-vault since it’s webdav fs which doesn’t provide all the functionality that Resilio relies on for efficient monitoring

Just bear in mind that the Archive folder that Resilio stores deleted files from other peers isn’t that useful for restore operations anymore, only for faster file move / renames, since the filenames are scrambled by cryptomator, but that’s a general usage issue if file level backup is needed for the vault


#5

Thank you! I will keep that in mind.