Copy & paste of password not possible in Cryptomator version 1.4.3 & 1.4.4

os:windows

#1

Hi,
I use cryptomator since 3-12-2017 and LIKE the product.
After upgrade from version 1.4.2 to 1.4.3 I receive a error after I copied and paste my password.

I tried and tested my password manually -> my password was OK.

I upgraded to latest version 1.4.4 -> same issue -> If you take notepad , type your password and then copy/paste this password into Cryptomator -> error Wrong password.

used files:
Cryptomator-1.4.3-x64.exe
Cryptomator-1.4.4-x64.exe
Windows 10 Build 1809 latest updates up to feb 2019

Note:
I use Keepass to store ALL my passwords and up to version 1.4.2 it worked.

Test can also -> just take notepad, type in your password, copy/past into Cryptomator and Cryptomator should unlock your drive.

Tested: revert back to version Cryptomator-1.4.2-x64.exe
Copy and Past of password working again.

Upgrade to version 1.4.4 -> again-> copy/paste of same password from same notepad -> not working !!!

Solution: Just type in manually and Cryptomator is working again.

Request:
Why is this cut/paste not working anymore?
Any plans to reverse this bug ?

Thanks in advanced.


#2

Thank you for your bug report! Cryptomator 1.4.5 has been released just now that fixes this bug. See more technical info here:


#3

I upgraded to version 1.4.5 and now I am not able to open the vault anymore -> error in logfiles ?? Where are the logfiles ??
Have now idea what is wrong ??

I reverted back to stabile version 1.4.2 and now a do not get a drivepointer in explorer anymore ??
what a nightmare …
any help to recover my files is welcome.


#4

Please install version 1.4.5 and then reboot your system. I had the same issue after upgrading to 1.4.4 and 1.4.5. in both cases reboot solved it for me.
Ps: on windows the log is stored at %appdata%


#5

I found the issue about non opening the vault anymore -> the same vault was open on another desktop.
Solution: Shutting down ALL active vaults and open ONLY ONE at once !!
Now I am able to open the Vault again … pfff …

Conclusion: Reboot all systems, who can open the Vault, before any Cryptomater update. ( to close any open vaults )

Checked again:
Upgrade from 1.4.2 to 1.4.3 -> copy & past unlock vault password works !
Upgrade from 1.4.3 to 1.4.4 -> copy & past unlock vault password works !
Upgrade from 1.4.4 to 1.4.5 -> copy & past unlock vault password works !

A Happy Cryptomater user again !!

Many thanks for the swift responce !

Note:
How to check for locked files on shared vault access:
There is a built-in function in Windows that shows you what files on the local computer are open/ locked by remote computer (which has the file open through a file share ):
Select “Manage Computer” (Open “Computer Management”) click “Shared Folders” choose "Open Files "

Now you can see the open files and who accessed these files in the vault on another desktop / Laptop
( Vault is located on windows share )


#6

If it says that you have the wrong password, that just means that there was no technical error in opening the vault, correct? I pasted and typed the password.


#7

Correct … After copy & Past PW from Notepad it just worked. Issue seems to be the last control character if you hit after typing your password.

The developpers are aware of that and probably check the input validation of PW again :slight_smile:

I will update my KeePass entry for ALL Passwords in my KeePass vault :slight_smile:
I think more website have this < last control char > issue in the password validation.


#8

What is the logic to have a password of 256 chars long ?

What is the Max password length in Cryptomator ?


#9