Copy files on a vault makes copy/paste fails

Hi there,

I try to put files on a vault, but when I copy/paste them, it fails everytime, even it’s a very small files :

I can wait hours, this copy will never ends. It makes crash my nemo application, so I can no longer copy files (in any other folders, not only the vaults).

I have all the permissions needed on the folder of destination. I am the owner of it, and it’s on 700 permission, so I could copy without problem.

If I don’t make this copy on a Cryptomator vault, the copy/paste function works fine. It’s after this test that it fails. I need to reboot my system to retrieve copy/paste functions, so it’s quite annoying.

I use desktop app, 1.4.15 version, on Ubuntu 18.04 (up-to-date). My vaults are on an external drive, with an ext4 file system (which pass all the tests of health).

Please help me because I cannot make any copy, I don’t know why.

Thank you.

This is odd. 19,3 kb isn’t even a lot of data. :thinking:

Have you chosen FUSE or WebDAV in Cryptomator’s settings to mount the vault?

FUSE is selected (not my choice, I guess it’s the option by default).

Should I choose WebDAV ? (i don’t know the differences between both…)

Worth a try.

If it is the same behaviour, this would be a hint that the underlying file system where the vault is stored is somehow blocking.

I’ve just updated to the 1.5.1 version. I wanted to see if the problem was still there with this version (I did’nt change the settings, it’s still FUSE).
Result : I have the same problem, with the copy which failed and never finish.
Then I wanted to close the vault to test with WebDAV, but here, I cannot close it ! I click on the “Verouiller” button (in french), and nothing happens.
I went to the Cryptomator/logs/cryptomator0.log (the last modified), and I saw this :

Caused by: org.cryptomator.frontend.fuse.mount.CommandFailedException: Command failed with exit code 1. Expected 0. Stderr: fusermount: failed to unmount /home/mentalo/.local/share/Cryptomator/mnt/2KyJMvS5QmRi_0: Device or resource busy
  at org.cryptomator.frontend.fuse.mount.ProcessUtil.assertExitValue(
  at org.cryptomator.frontend.fuse.mount.AbstractMount.unmount(
  at org.cryptomator.common.vaults.FuseVolume.unmount(
  ... 8 common frames omitted
18:35:16.944 [JavaFX Application Thread] DEBUG o.c.common.vaults.VaultStats - start recording stats
18:35:17.669 [JavaFX Application Thread] DEBUG o.c.common.vaults.VaultStats - stop recording stats
18:35:17.673 [JavaFX Application Thread] ERROR o.cryptomator.ui.common.VaultService - Failed to lock vault_name
org.cryptomator.common.vaults.Volume$VolumeException: org.cryptomator.frontend.fuse.mount.CommandFailedException: Command failed with exit code 1. Expected 0. Stderr: fusermount: failed to unmount /home/mentalo/.local/share/Cryptomator/mnt/2KyJMvS5QmRi_0: Device or resource busy
  at org.cryptomator.common.vaults.FuseVolume.unmount(
  at org.cryptomator.common.vaults.Vault.lock(
  at org.cryptomator.ui.common.VaultService$
  at org.cryptomator.ui.common.VaultService$
  at javafx.concurrent.Task$
  at java.base/ Source)
  at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
  at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
  at java.base/ Source)

First, I don’t know what to do. I can let the vault opened, but I shut down the computer every night, because I sleep near. So, will my vault be broken if I cannot close it properly ? Tomorrow, could I open it without problem ? :stress:

No and yes.
It’s safe to just shut down the pc (or kill the Cryptomator process) without actually closing the vault.
Please keep in mind, that file operations that may run during file process won’t be finished.
So this should just be a workaround to allow you a silent sleep. :smile:

1 Like

Ok I’ve kill the processus and open again the vault. Now I have 2 directories :
2KyJMvS5QmRi_0 -> empty, before I use this one (see the screenshot in #1)
2KyJMvS5QmRi_1 -> with the data
Is it normal ?
Should I remove the _0 directory ?
I’m so afraid to do something wrong and loose my backups…
Edit : another question… I don’t see in 1.5.1 version how to switch to webdav option… Is there a way ?

These are just the mount points that Cryptomator wasn’t able to clean up when it got killed.
No data saved in there. Feel free to delete any of these mount points that are not currently mounted.

1 Like

I have deleted the directories, while cryptomator was not launched, and no vault was mounting.
Then, I tried to mount the vault i’m using on this ticket. But it doesn’t work, I have this error :
What I was afrais is happening :frowning:
Thank you for your help.

It would be helpful if you post your french error messages as text here and not (only) as screenshot. So all the (not french speaking) people here do not have to transfer it char by char into an online translator to imaging what the message might say.
Of course it would be even better if the error messages would be translated directly by you into English ones :slight_smile:

To your error message: “The mountain point is not an empty folder”
This means that the folder you have configured in your setting as mount point is not empty. but it has to be empty.
So go into the settings of your vault and check which folder for the mountpoint is configurated. then go to this folder with your preferred file explorer app and check if the folder is empty. If not then choose:

  1. configure a different (empty) folder as mountpoint
  2. keep the already configured mountpoint in the settings, but delete all files manually in it before mounting your vault (check what you are about to delete before actually deleting it!. Make backups!)

(I recommend to start with option 1 if you are unsure)

Ok thank you. The vault had a personal path, maybe I choosed this option carelessly.
So I can now test if the initial problem is caused by the mount method. But I still not find how to choose webdav option, as adviced in the message #4 of this topic. Any idea ?
Thank you in advance.

In Cryptomator go to Settings (red frame), switch to tab vault drive (yellow frame) and here you find the the type settings (green frame)
Its either WebDV/Dokany or WebDAV/Fuse (dpends on your operating system).

Ok thank you @Michael. I thought it was a vault parameter, not an application parameter.
I try webdav.


In post #5 I wrote I was not able to close clearly the vault. Click on the Lock button, or close the app does nothing.
I have the same behaviour in the 1.5.4 version. But instead of kill the application, I let it opened, then I retried to close the vault later. Then, it coult be closed properly.

So I wonder : is it possible that it could be from encrypting/decrypting actions were still in progress ?
I cannot find the graphics of activity, as in 1.4 version (if it still exists : where to see them ?).
Because I don’t like very much to let my vault opened, even it’s in my personal computer. It’s like leave my house without locking with keys :smiley:

Thank you for your answer.