ChromeOS integration

Hi there,
up until now I have been using LUKS encrypted USB pendrives to transfer data between Linux machines. Recently I got myself a chromebook (lenovo ideapad duet 3) to cut down on size and weight for when I am travelling, but so far I have not been able to get LUKS support running in the linux vm. So, I was looking for an alternative and decided to give cryptomator a try. I created a vault on my linux desktop, then installed the google playstore version of cryptomator on my chromebook and added the vault. So far everything is working as expected, however, unlike on the desktop version, where I can set a custom mount point for my locally stored (USB drive) vault, on chromeos I can access the vault content only via the cryptomator app. I find this very limitting in the way I can use cryptomator, shurely, there ought to be a way to make the unlocked vault accessible via chromeos’s file manager. How do I set this up, is there some further app needed?

Any help or pointers will be much appreciated.

I have cryptomator installed on my chromebook two different ways:

1 - Android app from the playstore, as you described.

2 - Linux cryptomator app installed inside a chromebook “crostini” container.

As you say, method 1 does not give you any custom mount point (you have to access all files through the cryptomator app). It’s the same for an Android phone. But method 2 does give you a custom mount point… When I unlock a vault in the Linux container, it sets up a custom mount point that can be accessed by either Linux apps or ChromeOS itself. For example I can set my ChromeOS chrome browser dowload directory to an unlocked cyprtomator vault (in Linux files (home directory) .local/share/Cryptomator/mnt) and download my password manager backup directly into the vault.

In terms of how to install the cryptomator on LInux, personally I found that the appimage file worked better than the flatpak. The Flatpak did not seem to have the proper file permissions on my system. I’m sure there are ways to fix that using Flatseal but for me the AppImage was simpler.

By the way, the Linux app is free.

Oh, that is great news! How did you go about installing/running the AppImage in the linux vm? When I try to run it I get

$ ./cryptomator-1.6.17-x86_64.AppImage
$ cannot execute binary file: Exec format error

I have also tried to install the ppa version, but upon adding the ppa I get an error message about some key missing as well as that there isn’t any release file in the ppa. So apt won’t let me add the ppa.


That is strange that you had that error with the AppImage. I think maybe (?) the problem is you did not make the AppImage file executable. To do that

  • open a terminal window
  • go to the directory where the AppImage is stored.
  • Type the following: chmod +X cryptomator-1.6.17-x86_64.AppImage

Also i’m not sure if it makes a difference but i have the file in a subdirectory (Applications) of my home folder.

PS - I’m not sure if i misunderstood. i apologize if i’m telling you what you already know.

The AppImage is executable and I too try to run it from a subdir in my home directory. I wonder if the problem is with my CPU (a snapdraggon ARM CPU) not being compatible with the x86_64.AppImage? What CPU are you using?

Happy New Year

Yes, that is the problem. Cryptomator will support Linux-based aarch64/arm64 OSs with the upcoming 1.7.0 version.

1 Like

Is there any schedule when the 1.7 ARM version will become available?