Changing name of mounted drive is buggy

I tried to rename the mounted drive. First thing I noticed was, that I can only delete characters from the name that was already given, but I cannot add any. I uninstalled Cryptomator and reinstalled it. I set up the same folder with the same name again, and then the mounted drive was named like it was before “Encrypted Folde” instead of “Encrypted Folder”. I even restarted my computer. I can rename the drive in Cryptomator to something else, then it will take over the new name, but when I change it back to “Encrypted Folder” the mounted drive is called “Encrypted Folde” again - really annoying :stuck_out_tongue:
Does anyone have a solution?

Hi. The drive is named like your vault. If you want to rename the virtual drive you have 2 options.

  1. lock your vault, open vault settings, and change the name in tab 1 “General”. Then unlock your vault again. The virtual drive name changed accordingly. Please note: this will not change the folder name of your vault. If you add the vault to a mobile app, it will be shown with the old name.
  2. lock your vault. Remove the vault from the vault list. Rename the vault folder (the folder where the masterkey file is located). Add the vault again to your cryptomator. Now the vault is named like your vault folder and so is the virtual drive.

Hi Micheal,
thank you for your quick reply. Unfortunately, that is not exactly how it works on my side. I named the vault “Encrypted Folder”. I tried to rename the drive via right-click on the drive. I couldn’t type anything, but I was able to delete the r, now it’s called “Encrypted Folde”. When I rename the vault in Cryptomator, the drives assumes the new name, but when I change it then back to “Encrypted Folder”, the drive will be “Encrypted Folde” again.

Dont’t know how this is even possible. I can’tdo that :slight_smile:

Have you tried to remove the vault from the vault list and add it again?
Or maybe switching the volume type (back and forth) helps.

Yea, I have removed it, uninstalled Cryptomator and WinFsp and reinstalled it. The error even persists when I create a new vault in a different location and call it “Encrypted Folder”. Changing mounting methods doesn’t help either :confused:

maybe this?

1 Like

yea, it seems like this is the same problem - I tried the solution, but I ran into the same problem as the user in this post.