Cant write to vault located on CIFS-share

No matter if i use webdav or fuse, I cant write even the smallest file to a vault thats being mounted by Nemo in GVFS. This actually used to work.

I get “Input/output error” while writing a file, it shows up as zero-length.

I get the following exception in ryptomator while trying to write a file

18:34:52.918 [Thread-100] ERROR o.c.f.fuse.ReadWriteFileHandler - Flushing file failed. Exceptions occured while writing
	at org.cryptomator.cryptofs.fh.ExceptionsDuringWrite.throwIfPresent(
	at org.cryptomator.frontend.fuse.OpenFile.flush(
	at org.cryptomator.frontend.fuse.ReadWriteFileHandler.flush(
	at org.cryptomator.frontend.fuse.ReadWriteAdapter.flush(
	at ru.serce.jnrfuse.AbstractFuseFS.lambda$init$6(
	at jnr.ffi.provider.jffi.NativeClosureProxy$$impl$$14.invoke(Unknown Source)
	Suppressed: Operation not supported
		at java.base/ Method)
		at java.base/
		at java.base/
		at java.base/
		at java.base/
		at java.base/
		at org.cryptomator.cryptofs.fh.ChunkIO.write(
		at org.cryptomator.cryptofs.fh.ChunkCache.removeChunk(
		at org.cryptomator.cryptofs.fh.ChunkCache.invalidateAll(
		... 6 common frames omitted

Version 1.4.15
Linux Min 19.2

We recently released a hotfix for macOS but your stack trace actually looks quite similar. This may have been fixed in Cryptomator 1.4.17. Could you please test this version?

There is no Linux binary yet. Download “” here and execute the “”:

Edit: JRE 11 is at least required.

That’s where I ended up when I googled, but never tried shellscript in 1.4.17 for macOS. Will do tomorrow at work.

Well, on macOS you could just download the Cryptomator 1.4.7 binary directly. What I meant is, if you could test this again on Linux. But since we don’t have a binary for that yet, you have to test it via the aforementioned way.

I’ve also had issues with writing to Nemo/GVFS mounts on Mint. The solution for me was to make a standard mountpoint to a share, either through fstab or the mount command. davfs and cifs both seem to work fine. With SMB/CIFS it seems to help to declare the correct UID and GID values.

example command line for CIFS

sudo mount -t cifs -o rw,username=USER,password=PASSWORD,uid=$(id -u),gid=$(id -g) //SERVER/SHARE ~/CRYPTO/

example fstab line for WEBDAV
https://webdavserver/dav/ ~/CRYPTO davfs user,rw,noauto 0 0

1 Like

I ditched Mint for Ubuntu 19.10, tried buildkit of 1.4.17 for linux, same issue but different error
(i tried to copy the file to a vault)

19:21:21.925 [Thread-259] ERROR o.c.frontend.fuse.ReadWriteAdapter - chmod / failed.
java.nio.file.FileSystemException: /run/user/1000/gvfs/smb-share:server=<server>,share=docs/vaults/vault/d/EP/R63MNWEBFHXPXB7AVAGFU7FBNXH573/B5ESH3EBZUY4RJHAG27RVENP2P2YXHKEI4IGNXUERLTHY2B4AP6QY===: Operation not supported
	at java.base/sun.nio.fs.UnixException.translateToIOException(
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(
	at java.base/sun.nio.fs.UnixFileAttributeViews$Posix.setMode(
	at java.base/sun.nio.fs.UnixFileAttributeViews$Posix.setPermissions(
	at org.cryptomator.cryptofs.attr.CryptoPosixFileAttributeView.setPermissions(
	at java.base/java.nio.file.Files.setPosixFilePermissions(
	at org.cryptomator.frontend.fuse.ReadWriteAdapter.chmod(
	at jnr.ffi.provider.jffi.NativeClosureProxy$$impl$$7.invoke(Unknown Source)