Can't run portable software in a vault


#1

I have a Filezilla Portable with lots of ftp servers in my work. Filezilla is almost perfect although it stores passwords in plain text, so I usually have it inside a Veracrypt volume, inside Dropbox. The problem is that Veracrypt locks the file until you close it and them Dropbox syncs it. In a power failure, the file is not synced.

So I gave a try to cryptomator, but filezilla fails to run inside it (can’t find files, the exe fails…). Any idea? Thanks.


#2

Running exe files inside a network drive doesn’t seem to work too well. Currently, Cryptomator uses WebDAV to provide the virtual drive so there’s no direct fix or workaround that I can think of. The virtual drive has to be provided by another technology and we’re currently working on that. We’ve spoken of Dokany in the past but we’re probably sticking to FUSE (in particular jnr-fuse) for Windows as well.


#3

I thought that veracrypt also worked as a network disk (I’m not sure). And I also work with portable apps hosted in a NAS drive as a samba network drive in my laptop through wifi.
That’s was the main use of cryptomator for me :disappointed: I wanted to work securely in Dropbox with some portable apps (filezilla, radmin, thunderbird portable…)
Will it be solved in the near future? any workaround?
Thanks for your answer.


#4

I’m not entirely sure what technology Veracrypt is using on Windows but I don’t think it’s a network drive. And it’s also absolutely possible that SMB support is better on Windows than WebDAV support. As far as I know, we can’t use SMB with Cryptomator because SMB can only be used with standard ports on Windows. Either way, we’re focusing our efforts on FUSE now. We don’t have an ETA, thank you for your patience.


#5

Thank you. I have subscribed to your rss to read changelogs. Regards.


#6

Hello,

As mentioned already in https://github.com/cryptomator/cryptomator/issues/78 using Dokany doesn’t solve this issue.
Any idea why portable apps keep failing to run?

Thanks
Andi