Can't open video files

copied from my reddit post

I moved some files from a Veracrypt vault to a Cryptomator folder and it seems that some video files won’t open even in VLC. The error I am getting says something about the size is too big or something along those lines and surprisingly, if I copy the file manually instead of copying a bunch of folders, the file will work.

What gives?

EDIT: The exact error “the file size exceeds the limit allowed and cannot be saved cryptomater” when I try to copy the file out of Cryptomator’s video or if I try to zip it. The file’s size is really small (it’s smaller than 1 GB for sure).

EDIT2: It seems that everything works fine on macOS but not on Windows 10. I also tried this Windows: How to remove write protection from a file inside a vault but it didn’t help.

EDIT3: Seems like copying the file manually will work for a few minutes and then it will start showing the same error again.

Which version of cryptomator do you use?
If you are using dokany, which version of dokany do you have installed?

There was a problem playing VLC videos with dokany that was fixed with version 1.5.11

If you are using 1.5.11 with the latest dokany release, please open the log file and search for ERROR or WARN messages and provide them here in detail.

I tried to reproduce that with a 2GB video file (mov), but I can’t. While using WebDAV takes a view seconds to start, it the will play without any issues. Dokany plays also without any issues.

Hey, thanks for replying. Yes I am installing the latest release and here are the logs.

dvdnav error: Could not open Z:\filenmame.mpg with libdvdcss.
dvdnav error: Can't open Z:\filenmame.mpg for reading
dvdnav error: vm: failed to open/read the DVD
dvdnav warning: cannot open DVD (Z:\filenmame.mpg)
filesystem error: cannot open file Z:\filenmame.mpg (Invalid argument)

EDIT: My Dokany version is and Cryptomator is 1.5.11 (exe-190).

Oh I got it fixed. I didn’t know I could switch between Dukany and WebDAV. It seems to work now when I select Dukany but not with WebDAV. I can tell that Dukany feels slower than WebDAV and VeraCrypt/native performance.