Can't open existing vault copied


I’ve searched in the forum but just find one similar case of my issue with no solution, that’s why I create this new topic.

I am on OS windows10 64
When I try to open an existing complete vault (exactly it is a backup of my initial folder that I’ve choosen initialy for encrypting ; the folder is complete with cryptomator key & files encrypted with exactly the same name), I choose the cryptomator key then the program cryptomator propose to enter the password twice & create the vault although I have choosen the option “open” and not “create a new vault”.

Here are more details for better comprehension :
Cryptomator v.: 1.3.4

Step 1: I Click the add button and choose “open vault
Step 2: I navigate to the folder containing the masterkey file.
Step 3: I open the masterkey file
Step 4 : It looks like as if I asked to create a new vault and not open one

Is this because this is not the original folder but a copy of it (even if it is totally similar) ?
In that case, how is it possible to decrypt files, because I’ve got the entire copy of the vault with all files encrypted and the masterkey file ?

Thank you

I tried to reproduce this, but for me everything works fine when adding an existing vault.

Hello, I’ve progressed since my last comments : in fact, during my past tests, I have choosen a wrong folder where was only the masterkey with files encrypted but not in original folder architecture (folders “d” & “m” generated by cryptomator at first creation of vault), that’s why there was an error…
It’s my fault, after doing so many tests, I have made a mistake.
So, when you ask to open existing vault with the whole original content with masterkey and folders with datas embedded, it works !
In order to understand better Cryptomator, I have tried this time with only a part of subfolders copied in “d” & “m” folders ; with this test, I can open the cryptomator drive associated but there are no files in it, so I think that files are encrypted and divided by Cryptomator in different files and we need all of these files to get the original file decrypted.
Is there someone that has got informations about that ?

See here: