Cannot select vault files from WebDav


I recently installed Cryptomator on my Linux system and I cannot open vaults which are on a WebDav mounted in Linux with davs. The problem is that in the Cryptomator file dialog I cannot even navigate to the WebDav drive. Only my system drive is available. How can I open my vaults on my WebDav drive?

With Windows I can just easily navigate to the WebDav drive Cryptomator’s file dialog. I also read somewhere that Linux might require mounting via davfs2 instead of davs? Is that actually an issue?

Thanks for the great work and thanks for help.

Do you see a big green button after unlocking a vault?

Also, which distro are you on?

Thank you for your answer. I’m on ZorinOS 16.3 which is a derivate of Ubuntu.

Well, I think there is a misunderstanding here. I don’t even get to unlocking. I have a webdav drive mounted and I can navigate on it with Ubuntu’s default file explorer. However, when I click on “Open existing vault” in Cryptomator I cannot even navigate to my webdav drive as it’s not shown in Cryptomator’s file dialog (I can send screenshots if needed). So, my question was if I need to mount it differently, so that I can choose a vault stored on the webdav drive from Cryptomator.

Thank you.

Yes, please attach some screenshots.

Ok, here is the screenshot. On the left side you can see the default explorer. And you can see that I’m in the mounted Webdav.

On the firght side there is Cryptomator’s file dialog and from there I cannot access the mounted Webdav. When I navigate to “Other Locations” there is only my default computer drive displayed but not the mounted Webdav.

I hope it’s more clear now. I just want to be able to open a vault which is stored on the Webdav drive but I cannot navigate to it in Cryptomator’s file dialog.

@nadine In the left window, bookmark the mounted WebDAV by right clicking on the navigation pill in the side bar. Then it will be visible across all file selection windows (like the one on the right).

@pra9com I did what you said and bookmarked the mounted WebDAV. Still, it doesn’t show up in Cryptomator, see screenshot.

I also tested the LibreOffice file dialog and there my mounted WebDAV and also my external hard drives (connected via USB 3.0) are displayed and I cann access them in the file dialog, see screenshot.

So, this issue seems to be related specifically to Cryptomator’s file dialog. Do you have any ideas about that? I desperately want to use Cryptomator on my Linux system. Thanks.

@nadine In screenshot one (Cryptomator dialog), try selecting All files using the dropdown menu at the bottom right

@pra9com I tried selecting All files but I don’t even have this option in the dropdown. The only option is Cryptomator Vault. Any other ideas?

Yes. Even if you would be able to select it, you would right stumble into a bug. A WebDAV storage opened with your file browser (Nautilus) uses in the background GVFS, which is not compatible with Cryptomator.

davs is just the communication protocol, davfs2 is a programm in your linux distro. A good how to ca be found in the nextcloud docs:

1 Like

Thanks for the hint regarding davfs2. I will try that. However, I want to point out that none of the other drives is displayed. I would expect all of the following to be navigatable via Cryptomator’s file dialog:

  • Another partition of my internal SSD (named OS, available under /dev/sda3)
  • External hard drive (plugged in via USB 3.0 named Seagate Expansion Drive)
  • Auto-mounted WebDav (which is actually a Nextcloud instance)

You can see all of these in this screenshot in the regular file explorer in the background.

When I wrote my initial post I had just created a fresh Zorin 16.3 installation on my notebook setup as dual boot alongside Windows. To be honest, I would have expected Cryptomator to work out of the box with an Ubuntu derivative, such as Zorin. I don’t really understand why it is so complicated to just select vaults which are saved elsewhere than on the Zorin partition. Is this an issue on Ubuntu in general or is this a Zorin specific issue? I just want to understand better why this issue arises at all. Thank you.

I just mounted my Nextcloud as described in the link and like this it worked. I could finally get one of my vaults to appear in Cryptomator and I could unlock it. :raised_hands:

However, mounted like this, it’s so painfully slow. Just opening it in regular file browser and navigating is much slower compared to how my Nextcloud is mounted automatically using Zorin Online Accounts feature (I don’t know which technology is used in the background therefore). So, it’s not really feasible for everyday use. May be it makes sense if I just install the regular Nextcloud app and try this out.

The question remains how I can access vaults on my external hard drives. Any advice on this?

Are you using the flatpak version of Cryptomator? You can find the package type in the preferences, “About” tab:

If yes, then you need to allow Cryptomator to access other parts of the system. See Unable to mount from external or network drive · Issue #16 · flathub/org.cryptomator.Cryptomator · GitHub. In the text you find also a link to a graphical user interface (called “Flatseal”).

Yes, I use flatpak version of Cryptomator. The link solved my issues with selecting external hard drives. I could just run the command and it worked afterwards. Thank you @infeo ! Perhaps it would be a possibility to inform users about the limited directory permissions in the flatpak version, so that there’s less confusion.

One remark regarding the gvfs bug. I checked it and the auto-mounted webdav provided by Zorin Online Account connection indeed runs via gvfs. The path is /run/user/1000/gvfs&dav:host=[...],ssl=true,user=[...]. Will the gvfs bug be fixed soon?

Unlikely, it exists already for some years and cannot be fixed inside the Cryptomator app.

I use Linux Mint with Cryptomator.

I have not tried using webdav storage servers specifically, only I do have an option for you to try.

I mount most of my cloud drives using a program called Rclone. It has native support for webdav.

You can try using it to mount your webdav server in stead of whatever software you’re using today and see if it gives you better results.

Rclone is open source, works on Windows, Linux, and Mac.