Cannot copy git files into the vault

Hello! First of all, thanks for your great product, works very well for the photos etc. However I’m facing a trouble with my coding projects encryption (Visual Studio projects + git files): I can’t even copy my projects folder to the vault, it just seems to hang. - it stays like this for a decent amount of time already. I can’t be sure whether it is hang or just very-very slow. - the file it is being hang on is a small git file.

So my questions are: is Cryptomator designed to work with thousands of small files? Can the vault be used as a projects folder in Visual Studio where I can work with my code directly? Can it handle constant read/write of the small files at decent speed?


Update1: Actually, the progress continues, just very-slowly like it’s handling a few gigabytes-sized file instead of a few kilobytes.

Update2: After sometime the whole operation failed due to network error 0x80070035 (
Now I can’t even open the vault, or lock it in Cryptomator app: the app isn’t opening anymore (only empty window in the taskbar is showing up:
However the tray icon is still visible and context menu is opening, but whatever I click just opens a white empty window, no text no buttons etc., so the app seems to be dead, can’t even exit.
I’ve managed to force-kill it in task manager and restart, now the vault is in a locked state in the app, but the network drive in the explorer is still zombie. I could ‘eject’ it via explorer’s context menu (at some point it stopped to lag and I could operate with it) and the virtual drive disappeared. Then tried to unlock the vault and got the next error log:

Error Code V18O:SBOR:BJP5
org.cryptomator.common.vaults.Volume$VolumeException: org.cryptomator.frontend.webdav.mount.Mounter$CommandFailedException: Command failed with exit code 2. Expected 0. Stderr: ���⥬��� �訡�� 59.

���।�������� �⥢�� �訡��.

	at org.cryptomator.desktop@1.6.8/org.cryptomator.common.vaults.WebDavVolume.mountServlet(
	at org.cryptomator.desktop@1.6.8/org.cryptomator.common.vaults.WebDavVolume.mount(
	at org.cryptomator.desktop@1.6.8/org.cryptomator.common.vaults.Vault.unlock(
	at org.cryptomator.desktop@1.6.8/org.cryptomator.ui.keyloading.KeyLoadingStrategy.use(
	at org.cryptomator.desktop@1.6.8/org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(
	at org.cryptomator.desktop@1.6.8/
	at org.cryptomator.desktop@1.6.8/
	at java.base/ Source)
	at java.base/java.util.concurrent.Executors$ Source)
	at java.base/ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)
Caused by: org.cryptomator.frontend.webdav.mount.Mounter$CommandFailedException: Command failed with exit code 2. Expected 0. Stderr: ���⥬��� �訡�� 59.

���।�������� �⥢�� �訡��.

	at org.cryptomator.frontend.webdav@1.2.7/org.cryptomator.frontend.webdav.mount.ProcessUtil.assertExitValue(
	at org.cryptomator.frontend.webdav@1.2.7/org.cryptomator.frontend.webdav.mount.WindowsMounter.mount(
	at org.cryptomator.frontend.webdav@1.2.7/org.cryptomator.frontend.webdav.servlet.WebDavServletController.mount(
	at org.cryptomator.desktop@1.6.8/org.cryptomator.common.vaults.WebDavVolume.mountServlet(
	... 13 more

Hi. Which volume type have you configured in cryptomator? Looks like Webdav to me.
If I am right, I recommend to install WinSFP und select it.


Thank you, Michael! Indeed, FUSE mode works way better than default WebDAV, at least for now :slight_smile: Initial copying problem solved, hopefully it will be a great experience in Visual Studio as well.