Cannot connect to OneDrive Buisness

I cannot connect to my One Drive Buisness Account (Germany). On IOS the Error “MSALerrordomain-fehler -50000” shows. On Android the app just crashes when i try to login.

please help. Gerne in Deutsch.

I tried to reproduce that with my OneDrive4Business Account and do not have any problems with the iPhone app.
Based on some internet research, this error is thrown if you are not getting a token (or any response) back from the microsoft authentication server.
To come a litte bit closer to the point where the error happens, can you please describe step by step what you are doing and when the error is thrown.
Can you please check in your settings if the OneDrive connection is shown as “connected” and if yes please disconnect it first.

Can you please enable the debug mode and provide a log file (please mask all private information in it).

Hey. Thanks for the answer.

For Android: I open the app, the seetings say i am not connected to any cloud yet. i klick login in with OneDirve. The MS sign up screen opos up. I enter my E-Mail. Then my Password. I klick on “sign up” and nothing happens. the apps fails zur espond. then a window pops up telling me that crypotomator fails to respond, and gives me the option to wait or to close the app. I use a brand new samsug galaxy TAB A.

On IOS: I open the app, the seetings say i am only connected to icloud yet. I click on “add new tresor”, choose onedrive, app askes me if i want to allow a connection to and share information, i click continue, the loginin screen appears, i login, after pressing “sign up” the error appears from some seconds and i am back to start.!


i enabled the debug Modus, tried to login again, then clicked “send log-files” butthere are not files found.

where can i find the permission section?

some further infos: the buisness accout i use is from a university. they use sharepoint some how. i dont get the diffrence, or if this is important at all. the thing is: i am pretty sure all used to work fine some months ago.

when i connect to my private Onedrice account, all works just fine.

when i try to create a log file it just shows my connection / dissconnection to my icloud vault.

In your Microsoft account settings.

Actually I have no idea what’s going on. What I can say for sure is, that I can connect my OneDrive4Business without any issues with my iOS.
For whatever reason in your case the windows authentication process does not respond properly, and that does affect both apps as well.
I can imagine several causes for that like a malfunction of the windows service, a prohibition of access grant to „external“ apps (the admins in my company told me that is can be configured company-wide, but I did not find any further information via google), and others.

thank you with your help. i think i discoverd the reason. its a stupid one. since i use a licence from my university (/sharepoint) i do not have full admin rights. they must have recently made some changes so i am not able any longer to give apps the permission to connect to my account.

1 Like