Cannot access to my fault after crash

I use the 1.10.1 AppImage version, On Ubuntu 22.04 (64 bits).
I was transfering datas on my vault, then suddenly it closes itself (I don’t knwo why, I just had error of the transfer window).
I’ve tried to relaunch the app and resume the transfers, but now I’ve got this error:

Error Code N05M:VLUQ:VLUQ
java.nio.file.FileAlreadyExistsException: /home/myuser/.local/share/Cryptomator/mnt/Banques
	at java.base/sun.nio.fs.UnixException.translateToIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixFileSystemProvider.createDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createAndCheckIsDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createDirectories(Unknown Source)
	at org.cryptomator.desktop@1.10.1/org.cryptomator.common.mount.Mounter$SettledMounter.prepareMountPoint(
	at org.cryptomator.desktop@1.10.1/org.cryptomator.common.mount.Mounter$SettledMounter.prepare(
	at org.cryptomator.desktop@1.10.1/org.cryptomator.common.mount.Mounter.mount(
	at org.cryptomator.desktop@1.10.1/org.cryptomator.common.vaults.Vault.unlock(
	at org.cryptomator.desktop@1.10.1/org.cryptomator.ui.keyloading.KeyLoadingStrategy.use(
	at org.cryptomator.desktop@1.10.1/org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(
	at org.cryptomator.desktop@1.10.1/
	at org.cryptomator.desktop@1.10.1/
	at$ Source)
	at java.base/ Source)
	at java.base/java.util.concurrent.CompletableFuture$UniAccept.tryFire(Unknown Source)
	at java.base/java.util.concurrent.CompletableFuture$ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)

I close and relaunch the app, still the same error.
The app says it found a solution, but a click on “Find a solution” didn’t do anything.
Is my vault lost?
Thank you for your help.

1 Like

Hi. Maybe this helps? Error N05M:VLUQ:VLUQ - Won't open a vault · cryptomator/cryptomator · Discussion #3099 · GitHub

This topic says “remove the directory”. Is deleting data the proposed solution? I’m not sure to understand what I’ve to do.

Open /home/myuser/.local/share/Cryptomator/mnt/Banques in a file explorer or terminal of your choice. This is the mount point where the decrypted Cryptomator files will be mounted for this vault. If this folder is empty, delete it. Then unlock the vault again and everything should work as expected.

Thanks, it worked! :partying_face:

Shouldn’t the application delete the directory it created once the safe is locked?