Can’t open vault in onedrive on mac error: 91OE:23FV:GGRI

I am on an intel mac trying to migrate from boxcryptor for a few days. Suddenly yesterday I can’t unlock my vault. I get: “Error Code 91OE:23FV:GGRI
org.cryptomator.cryptolib.api.MasterkeyLoadingFailedException: I/O error”.
The exact same error printout (different file paths obviously) as in this thread Error 91OE:23FV:GGRI · cryptomator/cryptomator · Discussion #2704 · GitHub
I can unlock it on ipad/iphone without problems.
I can create new vaults on onedrive and unlock them on my mac.
Tried moving the vault, make sure permissions are ok for the vault files and that they aren’t offloaded, but no luck.

One solution might be slowly moving the files on my ipad to a new vault, but that wouldn’t ensure it won’t happen again.

Any suggestions on how to solve this would be appreciated.

No ideas on this?
Was hoping Cryptomator would be a suitable replacement for boxcryptor.

It would help if you provided more data on what version of Cryptomator you are running and what volume type and version number (WebDAV, FUSE-T, or macFUSE etc.).

I’ve had a similar (possibly same, can’t remember the exact code) error when macOS updated to a new version. I assume it was related to macFUSE and and OS update issue causing Crytomator to look in an “old place” for the vault. I fixed it by removing (not deleting the data) the vault in Cryptomator and re-adding the vault.

1 Like

Thanks for your reply!

I believe it is webdav. Cryptomator 1.6.17
I tried re-adding it several times but no go.

Just to try it out, I downloaded and tried mounting the onedrive with mountainduck, and then it works (with the integrated Cryptomator solution).

So I believe (I am just a user and not a programmer, so I may be totally off here) there is something about Cryptomator that isn’t able to handle the way macos handles directories that are offloaded.
I made sure the vault files were permanently stored locally, but it seems that is not enough. I do not have the space to have my entire OneDrive locally.

Mountainduck seems to solve it, so maybe I just need to use that as a solution.
Perhaps something that should be told to all of us users who used boxcryptor successfully and have followed the advice to switch to Cryptomator?

I tried emailing Cryptomator support, no answer yet.
Thanks again!

Any reason you are using webdav…and an old version of Cryptomator? Webdav on a mac is known to have issues. FUSE is recommended per the download page.

I just went with the default options. Went to download the version from the homepage and just ran with no modifications.
Will check if the app will update.

I think when I downloaded it in somewhat of a hurry it sounded as if fuse was unsupported and experimental.
As I said I am far from an expert, and when using boxcryptor being a naïve user worked fine :grinning:

Will look into it and see if fuse will solve it! Thanks for pointing this out.

FUSE-T is listed as experimental. FWIW it’s worked well for me. macFUSE is not listed as experimental.