Building Cryptomator from sources generates jar without fuse and dokany support?

os:windows

#1

Hi,

I just tried building Cryptomator develop branch with Oracle Java JDK 10.0.1 and Maven 3 using mvn clean install -Prelease.
The build completed without Errors but the resulting jar only shows WebDav support. Dokany and Fuse are missing.

I tried to change the dependencies to their latest develop branche versions but there was no change. What am I missing?

Greetings
Dennis


#2

You can only select FUSE or Dokany if their libraries are detected on the system. Furthermore it depends on operating system which mount method can be selected:

  • Dokany is only present on Windows
  • FUSE is only present on Linux and MacOS

#3

Thank you for the quick answer.

But it makes me wonder, why the prebuild jar that is downloadable on https://github.com/cryptomator/cryptomator/releases -> https://github.com/cryptomator/cryptomator/releases/download/1.4.0-beta2/Cryptomator-1.4.0-beta2.jar
offers me WebDav, FUSE (can’t work but is displayed) and Dokany when started Windows. And Dokany seems to be working just fine.
crypt%20fuse


#4

Because you talked about building from the develop branch :wink: The beta-2 had this bug of selecting an adapter even if it is not supported. This was fixed, some time ago, but after the beta-2 release.


#5

I somehow thought DOKANY was bundled with the jar so no further Installation would be necessary and I just got the bundle process wrong.

Thanks a lot :smile: