BUG: Right-clicking any file in Cryptomator pCloud vault crashes Windows Explorer (v1.12.3)

Running fully updated Windows 10 Pro with Cryptomator v1.12.13 and every time I right-click any file within my Cryptomator vault residing in pCloud drive using Windows Explorer, Windows Explorer locks up (hour glass/dimmed out) and cannot be restarted. Even using Windows Task Manager to restart Windows Explorer does not work. The only way I can recover Windows Explorer is by logging out and logging back in.

I never experienced this problem until now. I experimented with creating new and different vaults (e.g. WinFSP vs WinFSP local) within the pCloud drive and every time Windows Explorer locks up when I right-click any file within the vault. Note: this problem only occurs within pCloud drive; it does not occur within any other vault within any other local drive/folder.

As an experiment I reinstalled the pCloud app and Cryptomator v1.12.3, but the problem persisted. Then I decided to uninstall v1.12.3 and install v1.9.2 (which I found I still had on my PC from last year) and everything works as expected.

I have to get going with my day and haven’t experimented with other versions of Cryptomator just yet, but hope to do so later.

[Edit: additional clarification]

Just attempted to install v1.12.0 and it completely crashed. During installation (after uninstalling v1.9.2) it reported “Removing outdated WinFsp Driver”. After installation my taskbar disappeared and I could not get it back. Restarted PC and then created a new vault with default settings in the pCloud drive. Upon attempting to access the vault got an Error Code GH1B:GH1B:JCKJ. Looking under vault options I see the default volume type is WebDAV (Windows Explorer) and WinFSP is not even available! So much for trying this version… uninstalling.

Just installed v1.11.1 and WinFSP is still missing and only WebDAV is available, so I downloaded WinFSP from their Github page, the 2024 Beta. Created a WinFSP vault in my pCloud drive and the same thing happens: Windows Explorer locks up upon right-clicking a file in the vault. Uninstalling…

Installed v1.11.0 and finally I am able to right-click files within Windows Explorer and look at properties, cut, copy, paste, etc.

Tried v1.12.3 just to see and it still has the same problem.

So long story short, something happened between v1.11.0 and v1.11.1 that broke Windows Explorer functionality with Cryptomator vaults within pCloud drives.

I would have discovered this problem way before now, but I haven’t used Cryptomator for many months due to file timestamps not being preserved in pCloud. I finally decided to try it again since v1.12.3 supposedly corrects the timestamp issue, but now with the latest issue Cryptomator is still not usable for me.

Oh, that sound is like a big issue.

I also use pCloud.

I currently use Cryptomator Version 1.11.1 and I have no issues with right-click files within Windows Explorer with Windows 10 Pro.

So my understanding is that in a higher Cryptomator Version could be an issue?

Now I don’t dare to make an update.
I hope that an expert will speak up again here.

I will test this myself to confirm also.

I use pcloud but have not opened a database recently on Windows because I use Linux mostly.

@Anja001

So my understanding is that in a higher Cryptomator Version could be an issue?

1.11.1 does not work for me, but 1.11.0 does, so it appears you are not experiencing the problem. No idea what would happen if you upgraded to v1.12.x.

I just tested on Windows 11 and version 1.12.3

My Windows 10 machine is tied up right now.

I needed to upgrade from an older version and needed to uninstall an update the winsfp software. The installation program did this for me and it worked fine.

I can access the vault using my P Drive and everything works normally.

I will try again with Windows 10 when that computer becomes available, which won’t be for several hours.

Just tried this on my AMD Ryzen 5 PRO Win11 Pro up to date 21H2 - Cryptomator 1.12.3 - Default Volume Drive set to ‘Automatic’ on my pCloud Drive … Right Click OK, all working normally … All seems good :slight_smile: Something to do with the pCloud Sync maybe … just a thought …

2 Likes

Well there is one difference between our two setups. I do not use any sink software. The vault is stored on the pcloud drive and does not sink down to my computer for local access because the Vault will soon expand beyond the storage capacity of my local computers and I don’t want to keep data on my local computers. I do periodically back up to database to another Cloud Server and also in SSD drive

I have just one dedicated folder that I sync between pCloud and my PC, for the same reason

@LearningAsIGo If you look into the folder %localappdata%\Crashdumps (enter this path into the file explorer and hit ‘Enter’), is there a file named Cryptomator.exe.XXX.dmp?

@infeo Unfortunately there is nothing in the Crashdumps folder for Cryptomator.

This issue has been on my desktop… I’m going to update Cryptomator on my laptop and see if the same error occurs.