Blue/black screen on first vault attempt

I just attempted to install Cryptomater on a Windows 10 computer. Upon my first attempt at opening the newly created vault the whole computer went blue and black. The only way I could get out of it was by pressing the computer off button. Nothing else worked. There was a message on the screen (sorry I didn’t write it down), I panicked because the first thought was “oh my God, malware, I screwed!” I’m doing a scan right now (by the way I downloaded from the official Cryptomater website). Is this a known issue with Cryptomater? I confess that something like this pretty quickly gets above my knowledge level. Thanks in advance for any advice or insights.

  • bena


As far as I get it from your description, opening the application did not impose any problem and only unlocking a vault led to the OS crash. What technology are you using to unlock the vault? Dokany or WebDAV? You can find this setting in the virtual volume tab, general preferences.

Hello infeo,
Thank you for your reply! I looked in the virtual volume tab as you directed and it lists Dokany. I hope this helps.

  • bena

I thought so. As a workaround, you can switch the selection to WebDAV. It has some drawbacks (Capacity of Vault is shown as C drive, maximum filesize is limited to 4GB, slow), but it should work.

Regarding the crash: You can help us finding the cause by testing something. Dokany provides as a test tool an in-memory filesystem (i.e. after the unmount all data will be erased in the mount point) to see if there is an error in their library or at our side. Open cmd/powershell, navigate to the installation directory of Dokany, change directory further to \sample\memfs\ and execute

.\memfs.exe /l X /c /d

where X is a free drive letter of your choice. The temporary filesystem is mounted at the chosen drive letter and and also accessible from there. Check if it exists and that you can interact with it. After the test, terminate the program by hitting several times CMD+C in the terminal window.

Report back if it worked or not.

:warning: As this could also possibly cause a crash, please ensure no important work is runnning.

Alas infeo, I think I’ve let you down. I confess to being in over my head very quickly with any type of programming, etc. So, I tried following your suggestions but I’m obviously doing something wrong. I got as far as the installation directory of Dokany (I think) but could not get any further. Actually, I’m not sure I even was where I was supposed to be. Here is where I ended up:
C:\Program Files\Dokan\DokanLibrary-1.4.0
But from there I couldn’t get any further on what I was supposed to do, just error messages. Sorry. I’ll give it a try again if I understand clearly what I’m doing wrong. In the meantime, thank you your effort.

Installed Cryptomator & Dokani to evaluate product - started program set up test vault. Opened test vault and entered password - immediate BSOD! - Cryptometer immediately uninstalled. Up to date Windows 10 Pro 64bit.
I have no idea what happened but I cannot take any further risks with this software; which is a great pity.
If anyone wants further information to help understand what might have been the reason for this please ask.

Instead of Dokany, you can try WinFSP. After installation, open Cryptomator, open the general preferences and select FUSE in the dropdown menu of the virtual volume tab.

We would be happy to hear from the results!

Alternatively, you can provide some debugging information for the BSOD with Dokany.

Hello Infeo,
Thank you for your quick response and expressed interest in this issue, which I consider very gratifying.
To be clear, I cannot be certain what software caused the BSOD - maybe it wasn’t Dokany but I do know that was included by the installer.
What I did notice, much to my dismay, is that Cryptomator tried forcing me to set up the Dropbox vault on the ‘C’ drive and, as I was unable to change the entry to where it actually is on ‘D’ (‘C’ is a relatively small SSD and ‘D’ is a large spinner), I used the third entry that allowed me to specify the location. (I suppose I could have set up a junction or symlink on ‘C’ to reference the Dropbox on ‘D’ but wherever possible I try to avoid the use of junctions etc. as they are often unsupported especially during OS updates).
It was immediately after this that Cryptomator gave me the option of opening the vault which I did; unfortunately I didn’t get any further in my evaluation of Cryptomator against a competitive product, I am also testing, that has a couple of annoying drawbacks but hasn’t yet failed.
I have to make a decision soon and, even if this BSOD is due to my own lack of understanding, the BSOD indicates the potential for further ungraceful degradations upon failure. I don’t have a test rig that I can check Cryptomator with but, being at one time a systems engineer, I can appreciate the enthusiasm for Cryptomator.

As you kindly suggest I will mention this BSOD on the Dokany forum.
If there are any ‘simple’ questions I will gladly answer them (they’ll need to be simple for me to do so).
BTW I use Veracrypt ‘volumes’ extensively but I don’t encrypt the whole drive. And I occasionally get close to running out of drive letters.
Thank you so much for your time and interest.