"Automatic photo upload" doesn't upload automatically


I am facing a problem with my Cryptomator app. It does not upload my photos automatically, even after:

  • I toggle the “Activate” under Automatic Photo Upload in Settings
  • I choose the directory in “Choose vault to upload”, also under Automatic Photo Upload in Settings
  • I unlock the vault manually
  • I logged into my Nextcloud successfully

I’m using a Xiaomi Mi 9 with Android 10, connected to WiFi.

My logs.zip in debug mode: https://we.tl/t-bjRfPcJBLo


Hey and welcome in the community :slight_smile:!

I’m quiet sure that the problem is related to https://github.com/cryptomator/cryptomator-android/issues/174

Can you please disable the “Upload only WiFi” option and unlock the vault again or join the 1.5.0 beta which should fix this problem and report back if this helps?


Hello @SailReal,

After disabling “Upload only WiFi”, the automatic upload did work for 3 photos only. Then it stopped working again, even after:

  • Rebooting my device once again
  • Enabling / Disabling “Upload only WiFi” again
  • Selecting another NextCloud folder

So probably the only solution would be to update to the 1.5.0 beta. How could I do it?

Thank you!

You can use this link to join our beta but be aware that beta versions can contain bugs: https://play.google.com/apps/testing/org.cryptomator

If this doesn’t help it would be awesome if you could send us another log file.