Auto Photo-Upload on Android stopped working with error

Started using Photo-Upload some time ago. Suddenly it stopped working with a “general error”. I can find this entry in log-file for each try:

ErrorCode: PJ2D:5NHN

I	20210425163707.172	App	Cryptors service connected

I	20210425163707.179	App	Auto upload service connected

I	20210425163707.186	PhotoContentJob	Job rescheduled!

I	20210425163707.193	PhotoContentJob	Service is destroyed

I	20210425163733.708	App	Cryptomator v1.5.13 (2099) "APK Store Edition" started on android 11 / API30 using a SM-A515F

D	20210425163733.712	App	appId org.cryptomator

D	20210425163733.758	CryptorsService	created

D	20210425163733.799	AutoUploadService	created

I	20210425163733.807	PhotoContentJob	Job started!

I	20210425163733.906	FileUtil	Try to recover AutoUploadFilesStore using class c or a

E	20210425163733.911	PhotoContentJob	Failed to add image to auto upload list

org.cryptomator.domain.exception.FatalBackendException: Failed to recover AutoUploadFilesStore

	at org.cryptomator.presentation.util.FileUtil.tryRecoverAutoUploadFilesStoreDueToFileObfuscation(FileUtil.kt:230)

	at org.cryptomator.presentation.util.FileUtil.getAutoUploadFilesStore(FileUtil.kt:197)

	at org.cryptomator.presentation.util.FileUtil.addImageToAutoUploads(FileUtil.kt:155)

	at org.cryptomator.presentation.service.PhotoContentJob.onStartJob(PhotoContentJob.kt:52)

	at android.app.job.JobService$1.onStartJob(JobService.java:62)

	at android.app.job.JobServiceEngine$JobHandler.handleMessage(JobServiceEngine.java:108)

	at android.os.Handler.dispatchMessage(Handler.java:106)

	at android.os.Looper.loop(Looper.java:246)

	at android.app.ActivityThread.main(ActivityThread.java:8443)

	at java.lang.reflect.Method.invoke(Native Method)

	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:596)

	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1130)

Caused by: java.io.InvalidClassException: org.cryptomator.presentation.e.c; local class incompatible: stream classdesc serialVersionUID = 7809473971931047958, local class serialVersionUID = -2190476748996271234

	at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:624)

	at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1713)

	at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1594)

	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1872)

	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1412)

	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:427)

	at org.cryptomator.presentation.util.FileUtil.tryRecoverAutoUploadFilesStoreDueToFileObfuscation(FileUtil.kt:215)

	... 11 more

What i already tried without success:

  • create another vault and use it for photo-upload
  • enabling / disabling the auto-upload feature
  • disable “wifi-only” option

Any help is really appreciated.

Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

Oh crap! As you maybe noticed in the provided log, we already try to recover from this error but this is failing on your device, hmm but I’m not quiet sure why :thinking:. We introduced this problem in version 1.5.10 and fixed it in 1.5.13 but as already mentioned, the fix or workaround doesn’t work on your device. The easiest thing would be to delete the app storage or reinstall the app but however, you will then have to add the vaults again. Sorry for this inconvenience.

Thanks for the quick reply.
After reinstalling the app the upload works again.

1 Like
© 2021 Skymatic GmbH • Privacy PolicyImpressum