AppImage fails to run on Ubuntu 24.04 LTS

I download cryptomator-1.12.3-x86_64.AppImage on Ubuntu 24.04 LTS, and it doesn’t run at all.

Any specific timeframe to make it work on Ubuntu 24.04 LTS if it’s a known issue?

Just out of curiosity have you tried the flat pack version yet to see if that installs and runs? I will give the other a try later on.

See if I can duplicate your condition.

OK, @Ankush_Das

FYI Developers!

I just did a clean install of Ubuntu 24.04 and I have successfully reproduced the inability to execute 1.12.3-x86_64 of Cryptomator.

When I tried to run from the command line I received an error from or regarding fuse which is where I believe the problem is.

“dlopen() : error loading”

“Appimages require FUSE to run.”

Fuse3 is installed by the operating system by default but it is not what the software wants.

I ran:
“sudo apt install fuse”

This resulted in the installation of fuse version 2.9.9-8

It looks like I got downgraded from fuse 3 to fuse 2 and I was warned by the operating system that I was going to cause problems because fuse 3 is required for other features and software.

FUSE 3.14.0 was removed.

The installation of fuse2 resulted in the removal of about a half a dozen other apps as well. The operating system is not going to be happy.

After downgrading from fuse 3 to fuse 2 I am now able to successfully launch Cryptomator.

If any developers read this it is necessary for somebody to install the latest version of Ubuntu and determine what needs to be fixed or added or changed in order to make Cryptomator work properly on the latest version of ubuntu.

Additional notes. Thankfully I did this in a virtual machine and had created a snapshot prior to doing anything because the next time I tried to boot the computer it wouldn’t boot at all. Downgrading fuse destroyed the machine. Going back to the previous snapshot fixed everything.


Thanks for the detailed insights, appreciate it! Yes, this problem needs to be solved for Ubuntu 24.04 LTS users.

I would like to point out, I use Insync for syncing files and they’re prompt on making a package available for Ubuntu 24.04 LTS. I’d like to see that here. Hopefully, they look at this issue and work on it asap.

I tried the Flatpak package, and that worked! Thank you for a workaround.

I suggest Cryptomator devs add the Flatpak package as a recommendation on their website, considering it is officially being maintained by them.

1 Like

@infeo Just giving a heads-up! :grin:

1 Like

AppImage still needs fuse version 2 or more precisely libfuse2 to start (in general, not just the cryptomator AppImage), but instead of installing fuse, which removes fuse3 (required by some parts of Ubuntu packages), install libfuse2, which has no problems running alongside fuse3.

You can also use PPA and Flatpak.


Thanks for the solution!