After update do 1.5.8 migration error 'Vault version checker beforehand but not supported by migration'

We have around 6 persons sharing a vault using Dropbox, on Windows 10 and MacOS operating systems. After the upgrade, some were unlocking their vaults but not seeing any files, despite the files being present locally in the dropbox folder. We figure this could be related to the version stated in the masterkey not matching the version of the vault on their system, since some already had migrated their vaults while others haven’t done so yet. So we decided to manually change the version for those who haven’t migrated yet from ‘7’ to ‘6’, in order to trigger the migration. This seemed to work, immediately after changing the version, the files were visible again and not soon after that users were prompted to migrate their vault. However, after the migration starts this error appears:

java.lang.IllegalStateException: Vault version checked beforehand but not supported by migrator.
	at org.cryptomator.cryptofs.migration.Migrators.migrate(Migrators.java:115)
	at org.cryptomator.ui.migration.MigrationRunController.lambda$migrate$2(MigrationRunController.java:115)
	at org.cryptomator.ui.common.Tasks$TaskImpl.call(Tasks.java:139)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)

How can we solve this?

We already tried rebooting the systems several times.
Cryptomator version 1.5.8
Dokany version 1.4.0. (where applicable as a small number of users are on MacOS and thus using FUSE)

You shouldn’t just modify the masterkey file and only change the version value. The versionMac value also needs to be changed, which is used to prevent downgrade attacks.

Cryptomator creates masterkey backup files after every successful unlock and migration. Please use one of the masterkey files (probably the one that says version 7) and do not modify the file by yourself.

2 Likes

Makes total sense @tobihagemann and changing back to one of the bkup masterkeys solved and we managed to do the migrations. Thank you for your quick response.

1 Like
© 2020 Skymatic GmbH • Privacy PolicyImpressum