1.5 crashes on my mac

I installed version 1.5, and successfully migrated some of my vaults to format 7. Now Cryptomator crashes whenever I try to open it. I opens, because I see the icon in my dock, but then immediately closes. So, now I can’t access my vaults. I am using macOS 10.15.4. Any help?

Any suspicious entries in the log file?

Or does it crash before it is even able to write a log? Is there a crash dialog shown by macOS?

I tried reinstalling Cryptomator and in the process deleted the logs :frowning:
I took a quick look at them before and only saw the entries for upgrading the vaults, nothing new was written after it started crashing.
Now Cryptomator creates the log files cryptomator0.log and upgrade.log but does not write anything inside them.
Could it be a problem with the settings? I now remember that I changed some things there, like not starting Cryptomator automatically when I restart the computer. Where does Cryptomator store those settings? Perhaps deleting that could be a workaround the issue.

Yep, that was it, I deleted settings.json and I could start it. This is what I had there:

{
  "directories": [
    {
      "id": "Z94KFpzdxxxx",
      "path": "xxx",
      "mountName": "xxx",
      "unlockAfterStartup": false,
      "revealAfterMount": true,
      "usesIndividualMountPath": false,
      "usesReadOnlyMode": false,
      "mountFlags": ""
    },
    {
      "id": "0RqXl1Nxxxx",
      "path": "xxx",
      "mountName": "xxx",
      "unlockAfterStartup": false,
      "revealAfterMount": true,
      "usesIndividualMountPath": false,
      "usesReadOnlyMode": false,
      "mountFlags": ""
    },
    {
      "id": "qqHO2xEcxxxx",
      "path": "xxx",
      "mountName": "xxx",
      "unlockAfterStartup": false,
      "revealAfterMount": true,
      "usesIndividualMountPath": false,
      "usesReadOnlyMode": false,
      "mountFlags": ""
    },
    {
      "id": "5_yan8Auxxxx",
      "path": "xxx",
      "mountName": "xxx",
      "unlockAfterStartup": false,
      "revealAfterMount": true,
      "usesIndividualMountPath": true,
      "individualMountPath": "xxx",
      "usesReadOnlyMode": false,
      "mountFlags": ""
    }
  ],
  "askedForUpdateCheck": true,
  "checkForUpdatesEnabled": true,
  "startHidden": false,
  "port": 42427,
  "numTrayNotifications": 0,
  "preferredGvfsScheme": "DAV",
  "debugMode": false,
  "preferredVolumeImpl": "FUSE",
  "theme": "LIGHT",
  "uiOrientation": "LEFT_TO_RIGHT",
  "licenseKey": ""
}

Autostart settings are “stored” in your system preferences. You may remove it from there:

All other settings are inside ~/Library/Application Support/Cryptomator/.

Thanks! See my post above yours.

18 posts were split to a new topic: Add existing vault dialog does “nothing”

© 2020 Skymatic GmbH • Privacy PolicyImpressum