1.5.6 update won't work

I’ve just tried to update to 1.5.6. The menu icon appears, I can choose “Anzeigen” (“Show”?), the menu shows Cryptomator, but nothing happens. My vaults aren’t being mounted. I can only force quit.

So I have reinstalled 1.5.5 - works fine. Returned to 1.5.6 - same trouble.

I’ll stay with 1.5.5, but wanted to you know.

(MacBook Pro 15" Mid 2012, 10.15.5)

Is there anything suspicious in the log file?

cryptomator0.log (1.6 KB) cryptomator1.log (2.0 KB) cryptomator2.log (121 Bytes) cryptomator3.log (1.2 KB) cryptomator4.log (121 Bytes) cryptomator5.log (121 Bytes) cryptomator6.log (121 Bytes) cryptomator7.log (1.2 KB) cryptomator8.log (32.7 KB)

In 1.log ist eine Fehlermeldung - aber ich bin nicht sicher, ob das wirklich von 1.5.6 geschrieben ist. Wie gesagt: Ich komme zurecht, wollte Euch das nur wissen lassen.

Danke! Auffällig sind die Log-Files (wie z.B. cryptomator2.log), die quasi leer sind. Die Versionsnummer von Cryptomator steht in der ersten Zeile. Müssen wir erst mal überlegen und untersuchen, wie das sein kann. Falls wir noch weitere Infos benötigen, würden wir uns melden. Noch mal vielen Dank für den Fehlerbericht!

Erste Idee:

  1. Cryptomator 1.5.5 starten und den Debug Mode aktivieren.
  2. Cryptomator 1.5.6 starten, vmtl. wird’s wieder hängen.
  3. cryptomator0.log (aktuellste Log-Datei) schicken, falls dort neue Debug-Meldungen sind.

Zweite Idee:

  1. Cryptomator 1.5.5 starten und das automatische Entsperren für deine beiden Tresore deaktivieren.
  2. Cryptomator 1.5.6 starten.

Hier wäre es interessant zu wissen, ob Cryptomator 1.5.6 dann startet. Falls ja, versuch die Tresor mal zu entsperren. Ggf. geht irgendetwas beim automatischen Entsperren schief, aber diese These muss sich erst einmal bestätigen. :smiley:

Hallo Tobias, erst Spam, dann zuviel zu tun. Jetzt aber…

Erste Idee.cryptomator0.log (1.6 KB)

Zweite Idee: Ohne Wirkung. Bleibt dabei: Programm startet, Menüs sind da. Ich die Menüs öffnen, aber die Auswahl der Menüpunkte bewirkt nichts.

Vielen Dank für die Log-Datei! Wir untersuchen gerade, ob der mehrfache Aufruf von Starting JavaFX runtime... ggf. problematisch sein kann.

Nachdem du für die “zweite Idee” das automatische Entsperren deaktiviert hast und Cryptomator mit der neuen Version leider immer noch nicht startet, hättest du von diesem Fall auch noch mal die Log-Datei? Das wäre prima!

Edit: Hier übrigens auch mit aktiviertem Debug Mode.

Auch wenn wir nicht wissen, ob das wirklich den Fehler behebt, haben wir den mehrfachen Aufruf von Starting JavaFX runtime... behoben. Du kannst diesen Fix recht einfach testen:

  1. https://static.cryptomator.org/tmp/ui-1.5.6.jar herunterladen.
  2. Die Datei Cryptomator.app/Contents/app/ui-1.5.6.jar damit ersetzen (ggf. diese Datei vorher backuppen). “In die App” kommst du hinein, indem du einen Rechtsklick auf die App machst und “Show Package Contents” auswählst.

cryptomator1.log (1.8 KB)

Ist es die?

Hmmm.Bildschirmfoto 2020-07-07 um 16.44.05

Das ist der Versuch mit der veränderten ui-1.5.6.jar-Datei.

Okay, macOS ist vmtl. nicht zufrieden damit, dass Inhalte einer App einfach geändert werden, aber dies lässt sich meines Wissens umgehen, indem man Rechtsklick auf die App macht und “Öffnen” sagt.

Leider nein, das hatte ich gleich probiert…

© 2020 Skymatic GmbH • Privacy PolicyImpressum