[1.5.15 / 1.5.16] Cannot mount vault: Mount Timed Out

Hey Community,

since the issue still pops out from time to time, I decided to write a short post about a problem of Cryptomator 1.5.15 & 1.5.16 on Windows systems.

The Problem

You cannot unlock your vault, a cryptic error message is displayed with the request to contact us.

Use the following checklist, to see if you are in the right topic:

  1. You are using Windows 10

  2. Cryptomator version is 1.5.15 or 1.5.16

  3. In the general preferences, tab “virtual volume”, the option “Dokany” is selected.

  4. The cryptic error message contains the line:

  Caused by: com.dokany.java.DokanyException: Mount timed out

If all points apply, continue reading.

The Cause

The term “Unlocking a vault” describes technically a two step process. The first step is setting up all necessary objects to de- and encrypt your data, i.e. create a virtual filesystem of your data. In the second step this filesystem is integrated/mounted somewhere in the real filesystem. The integration functionality is provided by third party libraries, e.g. Dokany.

With Cryptomator 1.5.15 we improved the second step, such that Cryptomator notices if the virtual filesystem is suddenly unmounted. To achieve this we needed to change the communication between Cryptomator and Dokany. One of the changes is, that as soon as Cryptomator sends the mounting command to Dokany, it waits for a confirmation signal and if this is not given in a timely manner, Cryptomator assumes that something is wrong and aborts the whole process. While timely manner is a debatable formulation, there are users where even after 1 minute there was no signal.

We are still investigating, why Dokany does not signals it is ready, but up to now only assumptions exist. (see Mounted(): When is it executed? · Issue #992 · dokan-dev/dokany · GitHub)


Luckily, there are solutions.

Solution 1: Update Cryptomator to 1.5.16

Update to 1.5.16. In this version we increased the timeout significantly, such that also slower systems have enough time.

Solution 2: Update Dokany to most recent version

The developers of Dokany mentioned that external applications like anti virus software could inhibit the desired signal. In the update, apart from other things, the communication to the operating system is improved which might prevent it. You can download the installer Dokan_x64.msi from their release page: Release · dokan-dev/dokany · GitHub

Solution 3: Increase threshold manually

If the default timeout value is not sufficient and to give users a handle for a quick solution, we added in version 1.5.16 a configuration parameter to manually alter the threshold. In the installation directory of your Cryptomator application, navigate to app and open the file Cryptomator.cfg. (The default path is C:\Program Files\Cryptomator\app\Cryptomator.cfg). At the bottom section called [JavaOptions], add the following line:


The timeout value is given in milliseconds, so in the above example it is set to 30s. (see also Windows: Failure to open vault due to "Mount timed out" · Issue #1627 · cryptomator/cryptomator · GitHub)

Solution 4: Use WinFSP

If this still does not do the trick, you can try out a different library to integrate/mount: WinFSP. For more info, see WinFSP: How to use it


Solution: Switched Virtual Drive to WebDav.

Nothing was working mounting with Dokany kept timing out did everything up to solution 4. Antivirus I’m using NOD32 antivirus for the computer not working. Using Defender on my other computers without issue. I was about to do Solution 4 WinFSP. When I saw the other option in virtual drive that worked. Is there a issue using WebDav?

WebDAV has some limitations.
See here: 4 GiB file size limit on virtual drive

I also had some problems while trying to copy files to One drive. Once the folder is mounted using WebDav One drive has issues with the name of the path.

Solution 4 worked for me! Thank you :pray:

@JMM275 I also have problems with OneDrive and obfuscated folder and file names that are to long to be uploaded. Maybe we should open a separate thread for that?

Best regards

Updating Dokany solved the problem for me. Thanks!

As a general remark: This problem will be solved in next 1.6.0 release of Cryptomator.

1 Like

I got this error and “Solution 2: Update Dokany to most recent version” fixed it