1.4.13 (Windows): Files are never deleted

Hi all,

no files are deleted from a vault, neither when they are moved to another vault or partition, nor when they are deleted directly.

This holds for all PCs (four at the moment) on which I use 1.4.13 so far.

It is also independent from the file storage service that I use (so it is e.g. not a Dropbox Smart Sync issue).

Any idea what could help? :slight_smile:

Thank you and best,

What version of Windows and are you mounting it as WebDAV or Dokany?

I use Dokany on all machines.

The Windows versions are different. On one of the mentionned four installations that don’t work properly, I use Windows 10 Home with build 18362 (1903). On the other one it is Windows 10 Enterprise build 14393. I couldn’t check the other two yet.

However, I meanwhile installed 1.4.13 on a another PC on which the problem does not occur. It is Windows 10 as well, but build 17763 (1809).

After downgrading to 1.4.12, everything’s fine again. I just have the low-throughput problem then, which was apparently fixed in 1.4.13.

Additionally, latest finding. :slight_smile:

All problems that I reported so far hold for the software Total Commander, which I use for nearly all file operations on Windows. (And the problems also hold for version 1.4.15, by the way.)

But, using the standard Windows Explorer, everything works fine, both deleting and moving files.

When I activate a corresponding option in Total Commander (“use Explorer delete method”), deleting files works fine as well. But still, moving files (just copying and deleting?) still goes wrong (copy OK, but no deletion).

Unfortunately, I am going to be of no help with your problem. But, you may want to turn on debug mode and grab the logs as you re-create this problem to submit to the devs if no one else comes along to suggest possible solutions or reasons for this behavior.

Can you please check if your vault files are write protected and if yes remove the protection?

Thank you, I tried it but it doesn’t work.

Anyway, I guess a write protection would not explain why it works fine with Windows Explorer, but not with Total Commander.

Maybe in case of a write protection I would even get a warning after deleting/moving a file, which does not happen in my case. The files just “keep existing”, without a comment.

There are two things you can do:

  1. We introduced a new feature in 1.4.13 (access to the vault over a UNC path). Maybe this causes the problems. This feature lead to unkown behaviour, therefore we removed it again.
    Try out Cryptomator 1.4.15. This can possible fix your problem
  2. Update Dokany to We updated our dokany library, but it showed that there are downwards incompabilites in the dokany project.

Thank you very much. That was the solution. :slight_smile:

I updated from 1.2.1000 to 1.3.1000 and now it works fine again.

Maybe you should add a Dokany update checker to the next version’s setup file. :wink:

Thanks again.