Vault 999 is unsupported but everything is up to date

Hi everyone. I’ve been using pCloud as my main storage provider and used the desktop version to encrypt my photos to the cloud.

When I try to access them on my iPhone or iPad, they both come with the following error ‘vault 999 is unsupported. This vault has been created with an older version or newer version of Cryptomator.’ I’ve checked the masterkey and it confirms vault 999.

Could someone please explain how that’s possible when both my iOS version and my MacOS version are completely up to date and they’re not on any beta? The photos vault was only created today (At the time of writing 27/05/2022)

Thank you.

Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

Can you please open in the Cryptomator iOS app SettingsAbout Cryptomator. Which version is displayed in the title?

I’m asking because this message means currently, that the vault is in version 8 and it looks so that you try to unlock the vault with an old version of the old Cryptomator iOS app.

Hi, @SailReal thanks for reaching out quickly.

The version number is 2.2.5 (949)

Hmm, that is weird because it is indeed the latest version :thinking:

Can you please open the vault.cryptomator file in the root of your vault folder with an text editor, copy the content, paste it in e.g. and copy the result into this forum.

Should look similar to something like this:

  "kid": "masterkeyfile:masterkey.cryptomator",
  "alg": "HS256"
  "jti": "5230271c-bddd-4a24-92a5-5028adeeca14",
  "format": 8,
  "cipherCombo": "SIV_CTRMAC",
  "shorteningThreshold": 220

Or simply post the content of the vault.cryptomator file directly into the message, should look something similar to eyJraWQiOiJtYXN0ZXJrZXlmaWxlOm1hc3RlcmtleS5jcnlwdG9tYXRvciIsImFsZyI6IkhTMjU2In0........

1 Like

Certainly :point_down:

Hmm that looks good:

"format": 8,
"cipherCombo": "SIV_CTRMAC"
"alg": "HS256"


Yeah. Just to reassure you, the desktop app is also up to date too (1.6.10 (dmg-3659)) so I haven’t got a clue what’s happened.

I also tried without FaceID but that didn’t work either as I thought it was a glitch.


Can you please verify using the pCloud online interface, that a vault.cryptomator file really exists in the vault folder?

Yes, please see the screenshot for confirmation.

I’m totally puzzled by this since you’re saying that the vault is completely new and everything is up-to-date. This is what happens from a technical perspective:

If the file vault.cryptomator doesn’t exist, Cryptomator is assuming that it’s an “older” vault format (because in older vault formats this file really didn’t exist), i.e., it will check the contents of the masterkey.cryptomator file to determine the vault version. With new (or migrated) vaults, we’ve purposefully set it to 999 to deprecate the version number of the masterkey file so that the version number (“format”) from the vault configuration file is being used.

That’s why our assumption was that Cryptomator for iOS is unable to find the vault.cryptomator file (it thinks that it doesn’t exist). Because that’s quite possibly the only case when this exact error message appears. But maybe there is some bug in the logic there.

  • Does the path to your vault contain any special characters that we haven’t thought of? Even though I don’t think that this makes sense because Cryptomator is able to find the masterkey file but who knows…
  • What happens if you remove the vault on iOS and re-add it again?
  • Is this something that you can reproduce with a new vault? If yes, what are the steps? I already did some tests just now but couldn’t notice anything wrong.

Hi @tobihagemann and thanks for reaching out.

I know, I am completely puzzled by this too as I’ve never had any issues with this in the past. The OS of all platforms are clean and there’s plenty of storage space if Cryptomator needs it.

I can access the vault via the desktop app but not through my iPhone or iPad because of the issue.

Moving the vault makes no difference as the error still presents itself.

I’ll create another vault with the same files tonight or tomorrow as they’re only photos but there are over 3000 (it’ll take a while) so I am not sure if the number of photos is causing the problem? Probably not but just need to cover all bases.

I’ll also do another pass on the photo names to see if there are any special characters but there shouldn’t be.

Please expect another response over the weekend and thanks again for your help.

That shouldn’t be necessary. An empty vault would be enough for testing purposes.

That shouldn’t be necessary either because the error appears before the contents are accessed. What I meant was the “path to the vault”, something like “/path/to/vault”.

Ok, I’ve done that and it’s still coming up with the error on a fresh vault bearing in mind, that the vault was created first from the desktop and then trying to be accessed from an iPhone. Nothing was added, it’s empty.

To see if this issue is the same the other way around, I also created another vault first with iOS but used the desktop app to access it and interestingly, it works with no problems.

Ok, I’ve created another vault and done the same again and this time it has worked. I have no idea what happened but I can say everything worked out.

Thanks again, gents! Resolved in the weirdest possible way :sweat_smile:

We’ll keep an eye on it. It’s really hard to say what went wrong and there is, unfortunately, not enough logging in the iOS app to determine “why” the vault.cryptomator could not be found.

If you still have the “broken” vaults, you can try to rename vault.cryptomator to and then back to vault.cryptomator (e.g., via the pCloud online interface). Maybe there was just some weird hiccup on pCloud. But other than that, I’m out of ideas.

Apologies for the extremely delayed response. The vaults have been removed and new ones have been created. The issue is no longer present with the new one so possibly a corrupt process somewhere down the line.

Nonetheless thank you very much for your help and to you @SailReal

Have a great day!


Just wanted to let you know that I faced the same issue.

After playing around with Cryptomator, OneDrive and Mountain Duck, this issues appeared out of the blue. Tried several things but eventually a MacBook reboot fixed the issue. Using macOS Monterey 12.5.1.

I too faced the same problem. What I did was to rename the vault in the PC application and then tried to unlock the vault with the old name on the iOS application, and that message appeared. The problem was resolved by deleting the vault with the old name (path) from the list of registered vaults in the iOS application and adding a new existing vault. Note that deleting from the list does not delete the vault entity, so it is safe.
If the cause is the same one and I can be of help I would be glad.

Not sure, but I think I am able to reproduce that.

  1. create a new vault „foobar“ (in my case local on iPhone)
  2. go to files app and rename the vault folder „foobar“ into something else, or delete it.
  3. go back to cryptomator and unlock vault „foobar“ or go back in files app to mounted vault „foobar“ and trigger unlock process
  4. enter your password and unlock
  5. vault format 999 messages shows up.

So I think the message „vault 999“ is shown in iOS app if a vault folder was renamed or deleted or is not available for any reason and the vault format can not be detected.
The message should state that the vault folder is missing.

I have the same issue but slightly differing platforms. Created new thread here