V 1.4.2: Issue when saving PDF documents with Adobe Acrobat Reader

Hi all,

I just upgraded from Cryptomator 1.3.4 to 1.4.2 and since then I have issues when saving PDF documents.
I use Windows 10 Pro 64-Bit, Cryptomator 1.4.2 with Dokany and Adobe Acobat Reader DC 2019.010.20069.

When I edit a PDF document, for instance, highlighting or commenting, and want to save it afterwards, I receive an error message that the document cannot be saved, cf. the attached screenshot:

When I afterwards use the “Save as” option, no error message appears and the document is saved. Ultimately, I’m not prevented from saving my documents, but since I edit many PDF documents, the error is very annoying and time consuming.

Could you please fix this behaviour in a future release?

Thank you in advance and best regards

I have more or less the same problem, on Windows 7 and Windows 10.
Cryptomator 1.4.2. But it didn’t happen in 1.4.0.

When for example I open a document in Excel, Powerpoint from my Vault and I make changes to the document, I cannot save it.

But if I go to Save as… and change the file name, it works. But if I keep the same file name, it will not work.

But as I said, it worked in 1.4.0, but the problem reappeared with 1.4.2. I use Dokany.


Seems like the “save”-problem spreads… On github there is already an issue reporting problems with LibreOffice and Adobe InDesign.

Many thanks for solving this particular issue.

Yesterday I updated Cryptomator to V 1.4.3 and since then I can save my PDF documents properly again.

BUT: Unfortunately, I now have an even worse problem. Only today I experienced three Bluescreens caused by the Dokan Driver, cf. the attached screenshot:

Any hints how to solve this issue? With Cryptomator V 1.4.2 and Dokan I never had these issues.

i consider the save problem as solved. For the BSOD thing, I refer to Bsod: unexpected_kernel_mode_trap