Using cryptomator in gnome mounted Google drive


I’m having some problems using cryptomator with Google drive.
On my Ubuntu system, Gnome automatically mounts my Google drive, and that’s where I store the cryptomator vault. Sadly, I experience heavy performance issues: Creating an empty folder in the vault takes at least 10 seconds, if I enter it and go back up, it vanishes. I’ve tried creating folders in a vault that’s located on a physical drive, and in the mounted google drive itself, in both cases it works instantly. Is there anything I can do?

Additionally, if I try to copy a file (e.g. 1.3MB) into the empty vault in the google drive, it tells me there is not enough space, no matter the size.

Thank you in advance.

Edit: I also found this thread, but the suggested grive-tools seem not to be supported anymore.

I’m not using Ubuntu, but I am using Manjaro Linux. Google drive only works with Linux from a browser, (Firefox or Google Chrome). To use from the desktop with Cryptomator I used Grive version 0.5.0-9, and Grive-tools version 1.15-6 from the Arch AUR packages.
I the made a ‘Google Drive’ folder in my /home folder, then installed cryptomator java version stable Ver 1.3.5

Everything works super! Hope this is of some help to you…

As I already pointed out, the grive-tools maintainers announced that they won’t support it anymore, and I don’t want to find a new solution if it breaks in a few months.

Instead, I tried out grive2 which is a fork of grive, and I haven’t had any problems yet.

Good to hear you found a fix for your Ubuntu OS. :grinning:

UPDATE: The vault works with google drive/ gvfs. It is just super slow and hangs for every command. I guess it is the same problem as in link forum post. I have not understood the problem properly before posting, sorry guys.

I also use Ubuntu 18.04. Via online accounts I have my Google Drive mounted and fully syncable.

When trying to create a vault in the GDrive, the entire OS freeze for a long time, and sometimes get back to normal function. Usually when the OS recovers, Cryptomator freeze at the password creation.

I have successfully created a vault in my local Nextcloud sync folder.

I do not understand the part above that “google drive in linux only work from browser”? Since the drive is mounted and accessible, should it not be enabled for a vault?